Samba on Solaris 8

Arnold Andrews X-324-4292 aandrews at
Fri Oct 12 12:31:04 GMT 2001

> I tried compiling samba and followed the instruction(from
> samba-2.2.1a/packaging/Solaris/README)   to create the packge and  got the
> following error. I ran following commands in  source directory -
> A  ./configure --prefix=/opt ( to install it in /opt )
> B  make
> and I edited the INSTALL_BASE variable in  file and  run this to
> create the package
> ----------------------------------------------------------------------------
> -------
> # pwd
> /tmp/samba-2.2.1a/packaging/Solaris
> # sh
> Assuming Samba distribution is rooted at /tmp/samba-2.2.1a..
> ## Building pkgmap from package prototype file.
> ERROR in prototype:
>     no object for <checkinstall> found in search path
> pkgmk: ERROR: unable to build pkgmap from prototype file
> ## Packaging was not successful.
> The samba package is in /tmp


Sorry for the late response... If you are still having the problem...

When I created my package, I had to remove the line "i checkinstall" on line 11 
from the "prototype.master" file in the ".../packaging/Solaris" directory.

After that, the script worked fine.

Hope that helps,

Arnold Andrews
MCAD/Unix Systems Administrator
Seagate Technology

More information about the samba mailing list