connecton reset by peer - socket problem

John Chiu john-chiu at
Thu Oct 11 08:36:43 GMT 2001

hi don

thanks for replying me.  actually i tried removing that "allow hosts" line,
and the result was i couldn't get any windows machine log into samba at all.

i don't understand this since the samba has been running for 3 months
smoothly and recently these problems emerges and couple days ago it suddenly
dropped dead.  i tried to re-install the linux and samba, update to the most
recent packages and kernel, using the original smb.conf file, won't help.
and without the samba sunning, when the win98/me workstations can see all
machines in the network neighbourhood very quickly, but with samba running
then it'll be slow.  do i have to include the workstations' 192.168.x.x ip's
and netbios names in the "lmhosts" file?

another msg in the log would be "broken pipe" which never stops once it
emerges and i have to brutle reset the linux.  so ironic is that this
morning after i transferred all data back to the winnt/2k servers (access
from real ip nt/2k servers) the samba seem to be running fine again, but of
course this time only myself connects to it (fake ip) with very low traffic.

sorry for bothering you for so long a mail, but i'd appreciate if i can be
given any clue or insight to the solution.

thx a lot


----- Original Message -----
From: "MCCALL,DON (HP-USA,ex1)" <don_mccall at>
To: "'John Chiu'" <john-chiu at>; <samba at>
Sent: Thursday, October 11, 2001 9:05 PM
Subject: RE: connecton reset by peer - socket problem

> Hello John,
> this sort of thing usually points to a routing or network issue
> below samba;  I'm not familiar with networking on redhat, or
> ip aliasing on that platform, but assuming you have
> interfaces = 192.168.whatever/ 'realip'/'realipsubnetmask'
> along with your allow hosts line
> then I would start looking at my routing tables, etc. and reverse lookup
> implementation (samba has to do reverse lookups when allow hosts line is
> included)
> Another thing you could do to further isolate the issue is to temporarily
> REMOVE the 'allow hosts' line and see if WITHOUT this, the problem goes
> away.  If it does, it's then almost certainly a reverse lookup/routing
> issue.
> Hope this helps,
> Don
> -----Original Message-----
> From: John Chiu [mailto:john-chiu at]
> Sent: Wednesday, October 10, 2001 10:40 PM
> To: samba at
> Subject: connecton reset by peer - socket problem
> i set up a samba on redhat with a 192.168.x.x ip and and alias of a real
> ip.  on the lan i have win nt and win 2k with real ip that can access
> the samba without difficulty, but when the win 98/me workstations, with
> 192.168.x.x ip's, try to connect to the samba, it would be either very
> slow, or saying that the lan is busy, or cannot connect at all.  then,
> in the samba, i'll see the log saying that "error on writing 4 bytes to
> socket 5 (or 6), connection reset by peer, exit now...".
> and, the samba  does not seem to be visible on the "network
> neighbourhood" stably.  i have specifically written a statement of
> "allow hosts = 192.168.0. (followed with the real ips for the win
> nt/2k)" in the config file.  i'm very much annoyed by this.
> pls pls pls help to point out what have i done wrong
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:

More information about the samba mailing list