tdb-corruption with 2.2.2pre, 2.2.1a and 2.2.0a

cseip at cseip at
Mon Oct 8 01:14:02 GMT 2001


Sorry to disturb.

We've still got problems with tdb-corruption on Linux. We've tried 2.2.2-pre
from the CVS-branch, "use mmap=no" in smb.conf, "undef HAVE_MMAP" in config.h.
Nothing helps. After a while, some users can't log on and a view to
/var/lock/samba/sessionsid.tdb shows the following:

[2001/10/08 09:15:03, 0] tdb/tdbutil.c:tdb_log(342)
  tdb(/var/lock/samba/sessionid.tdb): tdb_oob len 876098382 beyond eof at 798898

As far as I can see, our machine doesn't match the criteria at all Don McCall

We don't use HP-UX but Red Hat 7.1, Kernel 2.4.9 (this happened with factory
2.4.2, too) on an Intel PIII 1 GHz. A pretty fast machine with 1 GB of RAM. We got 
two of those machines but tdb-corruption occurs on both of them. The corruption
even occurs when I use an older Samba (2.2.0a and 2.2.1a). It didn't occur for
weeks but now it happens all the time. I can't imagine faulty hardware to cause
this. On the other hand, Samba worked for weeks.

Any ideas what I could try next?

Thanks in advance,

Christian Seip

*** Achtung: Neue Adresse! *** Achtung: Neue Adresse! *** Achtung: Neu

Christian Seip                         Tel            (06386)  404 304
Diplom-Informatiker (FH)               Fax            (06386)  404 305
Petschwiesen 19                        Mobil          (0171) 61 70 886
66904 Brücken/Pfalz                    E-Mail     cseip at

More information about the samba mailing list