Samba sharing a samba mounted directory

Christopher Morgan chmorgan at
Wed Oct 3 23:22:04 GMT 2001

Alright, just so people don't waste any time on this I solved the problem.  The
ownership of the links was the issue.  When the ownership and permissions of the
symlink was set correctly it worked, which got me to thinking that it might be
an ownership issue with samba.  So I changed the guest user to root, from
nobody, and the problem was solved.  Final solution was to mount with uid=nobody
;-)  sorry to post so hastily


On Wed, 3 Oct 2001, Christopher Morgan wrote:

> I'm trying to mount a samba share from a w2k box and reshare that from the
> machine I mounted it under.  I can do this although for some reason I'm losing
> write permissions along the way.  I can write to it on the linux box but not
> through the share exported from the linux box.  I have the same problem if I
> create a local file system symlink to the w2k's mounted samba share, I lose
> write access here as well.  This looks to be a kernel security
> restriction/design feature, anyone have further information?
> Debian Woody, 2.2.16(I think 16) kernel
> Thanks,
> Chris
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:

More information about the samba mailing list