Samba 2.0.7 and Win98SE

MCCALL,DON (HP-USA,ex1) don_mccall at
Wed Nov 28 08:04:07 GMT 2001

Well, that's wierd...
Question; you have 2 win98se boxes that do NOT have this problem, and 
1 that does.  If you put in the exact same card from a win98se box
that WORKS into the one that doesn't, does it still fail?  And if it
does, take a look at the driver for the card in the win98se box that 
fails compared to the one that works - is the driver the same revision?
are the parameters for the driver the same?  If not, try copying the 
driver from the working pc over to the bad pc, and updating the driver
in the device manager....
I'm no pc expert, but it does sound more like a driver/hw issue on the 
win98se pc than anything in Mandrake...
If the above (at the card and driver level) don't take care of it,
check the tcpip settings between the two machines in the registry, although
this is a long shot...

-----Original Message-----
From: Foss.KS at [mailto:Foss.KS at]
Sent: Wednesday, November 28, 2001 10:45 AM
To: samba at
Subject: Samba 2.0.7 and Win98SE

	I have been having an irritating problem with my home network.  My
network consists of 1 PC running Mandrake 8.0 as the file server with Samba
2.0.7, three PCs running Win98SE and one PC running Win XP.
	I have had the network running for almost two years in various OS
configurations and for the most part have had smooth operations.  However,
my problem comes when I try and copy, move, or save any files over 15KB to
the Samba shares from one specific Win98SE PC.  I can perform actions on the
Samba shares and move them to the Win98SE PC but not the other way around.
What makes this so confusing is that I can have no problems moving files on
or off this machine from any other PC including the server.  I can mount the
Windows share with Samba and pull them from Win98SE PC.  As well, this
Win98SE PC has absolutely no problems transferring files from any PC except
the Linux machine.  The Samba log file for this machine states that there
was a "read socket error" in the util_sock.c" file and that the "connection
was reset by peer".
	Now to add another twist, I have put three different PCI ethernet
adapters into the Win98SE PC and all have the same issue.  But, I tried a
USB Ethernet adapter on this machine and it works perfectly (although very
slow).  I have moved the network adapter around into different PCI slots and
each card had difference chipsets.  I have physically checked the Cat 5
cable and connection and there are no issues with the line quality.

	Could my problem be associated with a transmit buffer setting on my
Win98SE machine or a read buffer setting in Samba?  The message in the log
file would drive me to believe that it is a problem on the Win98SE machine.
However, it could be anything and I can't figure out which machine the
problem resides on.  My only guess is that there is an issue with the size
of the transfer and that when I use the USB Ethernet adapter, the transfer
is slow enough not to overrun any buffers.

	Any help would be appreciated. 	I will attempt to get my smb.conf
file if needed.

Kevin Foss
Ottawa, Canada

To unsubscribe from this list go to the following URL and read the

More information about the samba mailing list