Win2k SP2 Printer problem

Daniel Teo danieltkh at
Wed Nov 28 05:05:02 GMT 2001

some recent solutions are using the

use client driver = yes

i also encounter the same problem .
but have yet to try this solution :)
others i cannot remember .... "_"

-----Original Message-----
From: samba-admin at [mailto:samba-admin at]On
Behalf Of Hal Vaughan
Sent: Wednesday, November 28, 2001 11:37 AM
To: samba at
Subject: Win2k SP2 Printer problem

For those who have been helping me or following the problem I've had of
printing from Win2k (SP2) system to a printer on a Linux (Mandrake 8.1)
server through Samba 2.2.1a, I have some good news and information that I
hope helps other people.  At this point I have established the problem is
NOT a printing problem.  It's a user/access problem that's connected with
using my server as a PDC and logging on to it with the Win2k boxes.

I had replaced the print command with a cp command, to copy the file for
later troubleshooting and to save paper while testing the system.  No
matter what I did, I could not print from Win2k (continual "unable to
create a print job" error messages).  I also could not see the printer
queue ("unable to connect" error messages).  Under a previous install I
could get both Win2k boxes to print out without any trouble.  What I did
not realize was that was BEFORE I had set up the server to handle logons
from Win2k boxes.

When I added the Win2k boxes to the local domain, the network ID wizard let
me add one user to the system from the domain.  I added that user.  From
then on, when I logged in to either Win2k box, when I logged on, I logged
on to the domain with my "normal" user name or I logged on to the computer
only (not through the network) as Administrator.  I had been testing the
printers on the network account.  Since I had the same name defined locally
on both boxes, I tried logging on to a box with the same user name, but
instead of logging on to the network, I logged on only to the
machine.  Then, when I tried printing, everything came out fine.

I think the entire problem was on the Win2k side -- the network user must
not have had the authority or permissions.  I'm still checking on that, but
right now I can verify that if I sign on to the network, I cannot
print.  If I log on to the computer only, I can print.

If anyone can point me to documentation or info on handling Win2k users and
their permissions on local machines when the account is on the PDC, I'd
appreciate it.

I hope this information is helpful.  I had seen several people on
newsgroups and other places with problems like this and, at least in this
case, a major difference depends on whether I log on to the Linux server or
just on the Win2k box.  I'm sure, after more work, I can work on the
permissions and differences between network and machine logons to solve
this.  If that info will help anyone, I can update people on what I find.

Hope this helps someone else.


"To everything there is a season and a time to every purpose under the sun."

To unsubscribe from this list go to the following URL and read the

Do You Yahoo!?
Get your free address at

More information about the samba mailing list