Who else can reproduce this problem?

junkmail junkmail at tomcat.umsl.edu
Mon Nov 26 18:30:04 GMT 2001

>I can reproduce this. But I think "it's not a bug it's a feature". Because 
>the folder you want to delete is open (in the right pane), you cannot 
>delete it. Try to rightclick an _unselected_ folder and delete it - this 
>will work, even in the left pane of explorer. It's like formating a floppy..

Thank you for replying Oliver.  Now I've got you and two others who can
duplicate it.

I'd like to just dismiss it as a quirk of the Windows Explorer of Windows
2000 but the thing is I CAN NOT REPRODUCE this behavior against ANYTHING
OTHER than a Samba 2.2.1a or 2.2.2 share - be it an actual Windows 2000
share, a Samba 2.0.9 share, the local hard drive, or a Novell share.
(Please nobody start pointing the finger at Novell, two of the four Windows
2000 boxes I tested from had no Novell client software installed and now
I've got other people from this list verifying the behaviour as well.)

My sense is that it there is a bug in Windows Explorer on Windows 2000 that
is somehow TRIGGERED by Samba 2.2.1a and 2.2.2 and it seems to be isolated
to the Windows Explorer of Windows 2000, using the Windows Explorer of
Windows 98 against a 2.2.2 share does not produce the problem.

I'm sure a lot of you think I'm making a mountain out of mole-hill but I
have two concerns regarding this matter which are important to me:

We are about to go very large scale with Samba where I work and map the "My
Documents" folder of Windows 2000 onto a Samba share for what will
eventually be about a 1000 users / 1000 Windows 2000 boxes.

My concerns about this are #1 - keeping the confidence of our PC support
staff - they are bound to run into this and ask me about it and probably
point out that the access denied problem doesn't happen against a real
Windows 2000 server so in there minds its Samba thats broken, whether or
not it is really a bug in Windows 2000 that is triggered by Samba, in their
minds it will be Samba thats broken.  Confidence in Samba by your PC
support staff is important.
 #2, it does make me just a little leary of what else haven't I found out
yet in regards to bugs that Samba 2.2.2 will trigger on Windows 2000.  I
mean perhaps whatever it is that Samba 2.2.1a and 2.2.2 do that Windows
Explorer on Windows 2000 doesn't like, maybe that same thing will cause
some other unexpected behaviour for other applications besides Windows
Explorer running on Windows 2000.

For the benefit of those who may not have read my original post see below:

Thankyou for reading,
Tom Schaefer
UNIX Administrator
University of Missouri Saint Louis

>I truely believe I've stumbled across a bug deleting directories.  The
>bug is either with Windows 2000 or with Samba 2.2.1a and 2.2.2.  I'd
>tend to think it was a Windows bug except that the problem does not
>occur against earlier versions of Samba.
>I've duplicated this problem deleting directories to Samba versions
>2.2.2 and 2.2.1a in various configurations running on several
>different Sparc/Solaris platforms and today I built Samba 2.2.2 on a
>I386/Redhat 7 platform and can still produce the same problem under
>this very different architecture.  This problem is four for four from
>the four Windows 2000 machines I've tried.
>I'm running Windows 2000 SP2 and all the other various updates, I
>believe all four Windows 2000 systems I've tested with are at SP2 so I
>don't know if it happens with Windows 2000 SP1, it does NOT happen
>using a Windows 98 SE system nor does the problem happen from Windows
>2000 SP2 to Samba servers of version 2.0.9.
>Some of you PLEASE try to reproduce this and post your results.  The
>problem is as such. I've tried to be as detailed as possible.  Please
>try to follow my instructions exactly.
>Using Windows Explorer, Explore a drive mapped to Samba share or just
>explore the share itself, it doesn't really need to be mapped.  The
>key is to be exploring it it in Windows Explorer.
>Ok, so you're in Windows Explorer exploring a Samba share or drive
>mapped to a Samba share.  The problem is in deleting a folder.  If
>there isn't a folder you can delete, make one.
>On the left pane of Windows Explorer you've got all the little yellow
>folders and plus signs next to them so you can expand them, and then
>the contents of the current folder are displayed in the right pane.
>IN THE LEFT PANE, left click once on the folder you want to delete.
>Its name will be highlighted and THE LITTLE YELLOW FOLDER ICON JUST TO
>THE LEFT OF ITS NAME WILL BE OPEN and the contents of the folder are
>displayed in the right pane.
>Press the delete key on the keyboard or pointing at the folder name in
>the left pane press the right mouse button and select delete from the
>drop down menu.
>Everything (if anything) in the folder will be deleted but not the
>folder itself.  You'll get "Error Deleting File or Folder, Cannot
>remove folder xxxx: Access is denied, the souce file may be in use." 
>Click OK so the error goes away, then try deleting the folder a second
>time and it will then delete.
>I've tried everything I can think of to narrow down or find a reason
>for this, both on the Samba side and the Windows 2000 side.  All to no
>So, who else can reproduce this?
>Tom Schaefer
>Unix Administrator, University of Missouri St. Louis

More information about the samba mailing list