New to Samba: Please help

Brown, Tony TBrown2 at
Mon Nov 26 10:40:09 GMT 2001

Hi All,

I am new to Samba, and I am having problems getting Samba configured

I installed Samba on a Tru64 version 4.0f Server.  

My smb.conf file is pretty simple:

   workgroup = nmff-net
   server string = Samba Server
   log file = /usr/local/samba/var/log.%m
   max log size = 50
   security = user
   socket options = TCP_NODELAY
   local master = no

   comment = Home Directories
   browseable = no
   writable = yes

# The first share attempt
        comment = A test share
        path = /tony
        public = no
        writable = no
        valid users = tbrown

After putting smbd and nmbd in the startups and configuring swat in my
inetd.conf and services, I am running into 2 problems.

1.  I can not connect via swat as root.  I can connect as other users but
when I try as root, or admin, I get 
"401 Bad Authorization, username or password incorrect".  I even tried
adding the root user to the smbpasswd file by issuing "./smbpasswd -a root".
I still get the error for the root user.  
2.  I am unable to connect to my share.  In network neighborhood from my NT
machine, I can see the server.  However, whenever I double click the server
I get "UnixA not available, the network path was not found.  From the
command line, if I try net use z: \\unixa\test, I get "the network path was
not found".
I also tried security = share but I got the same results.
Initially, when I tried to add the root user I got an error that pointed to
/usr/local/samba/lib/smbpasy.  I created that file and did not get the error
after that file existed.  I also copied smbpasswd to smbpasy.
What did I do wrong?

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list