Who else can reproduce this problem?

Alexander Seitz Alexander.Seitz at fhs-hagenberg.ac.at
Mon Nov 26 09:58:09 GMT 2001

hm I know this but it is no bug. (maybe you can call it a w2k bug)

w2k can't delete the folder because you are veiwing the contents folder in
explorer and windows thinks it is still in use by the system and can't
delete it.
The same behaviour when a folder is sitting on a w2k server.
You have to delete the folder from the right pane and it will work just


----- Original Message -----
From: <junkmail at tomcat.umsl.edu>
To: <samba at lists.samba.org>
Sent: Monday, November 26, 2001 6:14 PM
Subject: Who else can reproduce this problem?

> I truely believe I've stumbled across a bug deleting directories.  The
> bug is either with Windows 2000 or with Samba 2.2.1a and 2.2.2.  I'd
> tend to think it was a Windows bug except that the problem does not
> occur against earlier versions of Samba.
> I've duplicated this problem deleting directories to Samba versions
> 2.2.2 and 2.2.1a in various configurations running on several
> different Sparc/Solaris platforms and today I built Samba 2.2.2 on a
> I386/Redhat 7 platform and can still produce the same problem under
> this very different architecture.  This problem is four for four from
> the four Windows 2000 machines I've tried.
> I'm running Windows 2000 SP2 and all the other various updates, I
> believe all four Windows 2000 systems I've tested with are at SP2 so I
> don't know if it happens with Windows 2000 SP1, it does NOT happen
> using a Windows 98 SE system nor does the problem happen from Windows
> 2000 SP2 to Samba servers of version 2.0.9.
> Some of you PLEASE try to reproduce this and post your results.  The
> problem is as such. I've tried to be as detailed as possible.  Please
> try to follow my instructions exactly.
> Using Windows Explorer, Explore a drive mapped to Samba share or just
> explore the share itself, it doesn't really need to be mapped.  The
> key is to be exploring it it in Windows Explorer.
> Ok, so you're in Windows Explorer exploring a Samba share or drive
> mapped to a Samba share.  The problem is in deleting a folder.  If
> there isn't a folder you can delete, make one.
> On the left pane of Windows Explorer you've got all the little yellow
> folders and plus signs next to them so you can expand them, and then
> the contents of the current folder are displayed in the right pane.
> IN THE LEFT PANE, left click once on the folder you want to delete.
> Its name will be highlighted and THE LITTLE YELLOW FOLDER ICON JUST TO
> THE LEFT OF ITS NAME WILL BE OPEN and the contents of the folder are
> displayed in the right pane.
> Press the delete key on the keyboard or pointing at the folder name in
> the left pane press the right mouse button and select delete from the
> drop down menu.
> Everything (if anything) in the folder will be deleted but not the
> folder itself.  You'll get "Error Deleting File or Folder, Cannot
> remove folder xxxx: Access is denied, the souce file may be in use."
> Click OK so the error goes away, then try deleting the folder a second
> time and it will then delete.
> I've tried everything I can think of to narrow down or find a reason
> for this, both on the Samba side and the Windows 2000 side.  All to no
> avail.
> So, who else can reproduce this?
> Thankyou,
> Tom Schaefer
> Unix Administrator, University of Missouri St. Louis
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list