Win2k Printing Problem

Joel Hammer Joel at
Sun Nov 25 09:58:02 GMT 2001

You have three printer shares defined in your smb.conf file. It might be
best to remove the two not being used, just in case you are confusing
your client. I would leave in only the [EpsonC60] share.
You do not have a guest account defined in global. I would try ftp. Then, if
that isn't working, I would try root. (I know, not very secure but this is
trouble shooting.) Frequently, obscure problems are permission problems. Using root
as the guest account should take care of that.
I would also add security = share in global to allow anyone to log onto your printer
share, since you have guest ok = yes in that share.
I would set log level = 3 and pour over the data there. That is often a good
clue. Maybe the error is not due to the printer.
I had to set log level = 6 recently to find out what the value of J being
sent by the client was during printing.
You are usually better off using native windows drivers. However, if you
want to experiment, you could pick a generic postscript driver. I am having
good luck printing from win4lin with a HP laserjet postscript + to my samba
server, which has no trouble converting the postscript file to a format for
my lexmark printer. I have found that not printing, just saving the file as
you are doing, and reading the postscript formatted print job with gv a time
saver and paper saver. 
If the test page prints but the application does not, you may be using
different queues for the two jobs OR the test page is being sent in a
different format than the job sent by the application. 

 On Sun, Nov 25, 2001 at 11:58:38AM -0500, Hal Vaughan wrote:
> I have a problem with Windows 2000 (SP2) printing to an Epson C60 on a 
> Linux server (running Mandrake 8.1 and Samba 2.2.2 with Cups 1.1.12).  I've 
> scoured the net and posts on Usenet have not yielded any helpful response.
> I have 2 Win2k boxes and they both respond differently, but neither is 
> printing.  I've installed the printer on both boxes.  On one I get a 
> "unable to connect" error from the Win2k Printer Queue window and every 
> time I print a test page, I get "unable to create a print job."  (The 
> lights on the hub blink to show the Win2k box and server communicate, but 
> there are no error messages at log level 2 -- there are so many messages at 
> log level 3 with it giving a continual stream of messages, but I cannot 
> find error messages at log level 3 that apply to the printer.)
> The other box can read the queue and print test pages, but is not printing 
> other pages from other programs.
> Right now I've replaced the print command with a copy command and a touch 
> command to help me w/ troubleshooting.  The printer has been tested with 
> CUPS and does work.
> I've tried using HOSTS ALLOW = and setting PRINTER ADMIN =, but they don't 
> help.  (When I use HOSTS ALLOW, I don't but a $ on the end of the host 
> name, right?)
> The threshloc in the conf file is a local group.  I'm logged into both 
> computers with the same user name and the user is in threshloc.  Even 
> though I have a PRINT$ share set up, I'm still not clear how to set up the 
> drives in the share and I'm not sure that would help, since I have drivers 
> installed and that was no problem.
> Would it work better if I set it up to use the drivers on the Linux box 
> instead of client side drivers?  Is there a compatibility problem using the 
> Linux drivers for material coming from Win2k boxes?
> Any help is appreciated.  I've been on this for a week and have not found 
> anything helpful in searches and have not received suggestions on 
> posts  (actually 1 suggestion that lead to adding the valid user parameter, 
> which does not seem to help.)
> Thanks for any suggestions you can give me.
> The smb.conf file is included below.
> Hal
> # Samba config file created using SWAT
> # from UNKNOWN (
> # Date: 2001/11/22 18:20:34
> # Global parameters
> [global]
>          workgroup = THRESH.LAN
>          netbios name = WOGGLEBUG
>          server string = Samba Server %v
>          encrypt passwords = Yes
>          log file = /var/log/samba/log.%m
>          max log size = 50
>          socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
>          printcap name = lpstat
>          add user script = /usr/sbin/useradd -d /dev/null -g machines -c 
> 'Machine Account' -s /bin/false -M %u
>          logon path = \%M\%U
>          logon drive = H
>          domain logons = Yes
>          os level = 33
>          dns proxy = No
>          wins support = Yes
>          path = /var/spool/samba/
>          create mask = 0777
>          directory mask = 0777
>          printing = cups
>          printer name = EpsonC60
>          log level = 2
> [homes]
>          comment = Home Directories
>          read only = No
>          browseable = No
> [printers]
>          comment = All Printers
>          path = /var/spool/samba
>          valid users = @threshloc
>          create mask = 0700
>          guest ok = Yes
>          printable = Yes
>          printing = Cups
> #       print command = lpr-cups -P %p -oraw %s -r # using client side 
> printer drivers.
>          print command = cp %s /home/freeall/%p.tst ; rm %s ; touch 
> /var/spool/samba/Tested
>          use client driver = Yes
>          browseable = No
> [EpsonC60]
>          comment = Epson Stylus C60 General Purpose printer
>          printable = Yes
>          printing = Cups
>          valid users = @threshloc
>          path = /var/spool/samba
>          guest ok = Yes
> #       print command = lpr-cups -P %p -oraw %s -r # using client side 
> printer drivers.
>          print command = cp %s /home/freeall/%p.tst ; rm %s ; touch 
> /var/spool/samba/Tested
>          use client driver = Yes
> [print$]
>          comment = Printer Drivers
>          path = /usr/local/samba/printers
>          guest ok = yes
>          browseable = yes
>          read only = yes
>          write list = root
> [data]
>          comment = Data file share and server for thresh.lan
>          path = /thresh/data
>          read only = No
>          inherit permissions = Yes
> [server]
>          comment = Program/file server for thresh.lan
>          path = /thresh/server
>          read only = No
>          inherit permissions = Yes
> "To everything there is a season and a time to every purpose under the sun."
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:

More information about the samba mailing list