Spool filename. ( What is the problem? )

Joel Hammer Joel at HammersHome.com
Wed Nov 21 08:49:25 GMT 2001

In 2.2.2 %s will hold a somewhat truncated version of the windows file, not
the smb.XXXXX job name. I am using windows 98. Have you just tried dropping the -J paramater and
see what happens?
I have never seen the J variable in any samba documentation. Undocumented
things tend to get lost over time, IMHO.
On Wed, Nov 21, 2001 at 12:23:01PM -0300, Daniel William Schultz wrote:
> Here is my printer config:
>     printing = lprng
>     load printers = yes
>     use client driver = yes
>     printer admin = @edutec, root
>     printcap name = /etc/printcap
>     print command = lpr -U%U@%M -r -P%p -J'%J' %s
>     lpq command = lpq -P%p
>     lprm command = lprm -U%U@%M -P%p %j
>     lppause command = /usr/sbin/lpc -U%U@%M hold %p %j
>     lpresume command =/usr/sbin/lpc -U%U@%M release %p %j
>     queuepause command = /usr/sbin/lpc -U%U@%M -P%p stop
>     queueresume command = /usr/sbin/lpc -U%U@%M -P%p start
> On the print command I have put the variable %J , to get the original 
> filename, but it's empty...
> On samba 2.2.1a it worked, but now in 2.2.2 seems to not work.
> This variable get deprecated ?
> Please, any help is welcome, my boss is asking me all the time about 
> this, and I don't want to downgrade to 2.2.1a to have oplock problems 
> again :)

More information about the samba mailing list