Appleshare IP 6.2 and smbfs

William Mulvihill will.mulvihill at
Wed Nov 14 13:38:02 GMT 2001

	I'm having trouble connecting to an Appleshare IP 6.2 Mac that is 
doing SMB file sharing from my RedHat Linux 7.2 box.  I've looked and 
looked and looked at many things and many SMB clients.  I've tried 
smbclient, smbmount, Sharity, and even just doing a mount -t smbfs.  All 
of them come back with something of this form:
Protocol Negotiation Failed
SMB connection failed.

	I have tried using samba 2.2.1a, samba 2.2.2.  I have upgraded my 
kernel from 2.4.9 to 2.4.13 in the hopes that some of the smbfs fixes in 
2.4.11 would help.  None of this has helped.  What is funny is that I 
can use samba to connect to every other Windows shared directory.  Works 
like a charm.  I can mount Windows machine's shared files, but cannot 
connect to this Mac serving Windows files.  Using verbose modes of 
smbclient and such don't yield any useful lines.  And I know my DOMAIN 
is set up correctly.

	The absolute last thing I haven't tried yet is to upgrade the 
Appleshare IP Mac to 6.3.2.  But to do that, I need to upgrade the 
entire OS from 8.6 to 9.0.4.  While this is doable, it would be nice to 
avoid this.  This is our main file server and I'd like to know if the 
upgrade would definitely fix this.  Has anyone had success using samba 
with Appleshare IP???  Anyone???  I googled the web.  No one seems clear 
on whether this will work.  If I am asking the wrong person about this, 
please let me know who I should direct my questions to.  Thanks.

William Mulvihill, Web Master
DxR Development Group, Inc.
150 E. Pleasant Hill Road
Carbondale, IL 62901
phone (618)453-4789
free  (800)453-8040
fax   (618)453-5309

More information about the samba mailing list