Write security over Samba share?

Brad samba737 at netscape.net
Sun Nov 11 20:30:08 GMT 2001

I have  RedHat 7.2 Workstation that is using Samba to attach to a RedHat 6.0 Server share. I have inserted the following entry in /etc/rc.d/rc.local on the workstation:

mount -t smbfs //office/Shared /mnt/shared -o username=xxxx,password=xxxx

Access is fine, but I am unable to write to the share. I have Chmod-ed, Chown-ed and Chgrp-ed the share so that it is completely available with no limitations at all, but I still can't write to it. When I su - to root , I can write to it OK.

According to the mount docs, by default it gets mounted in read-write mode, but I have also tried to add the -w (write) option anyway, but still no go.

I have then added a similiar entry into fstab and specified rw (read-write) for the mount, but still no-go. I can read fine, but not write over the share. I can log in the the server with the same username and password and manually go to the shared directory and write with no problems, so it must have something to do with the share security.

Can anyone shed any light on this?


Your favorite stores, helpful shopping tools and great gift ideas. Experience the convenience of buying online with Shop at Netscape! http://shopnow.netscape.com/

Get your own FREE, personal Netscape Mail account today at http://webmail.netscape.com/

More information about the samba mailing list