Question regard an IPC$ error with Windows 98 Clients.

Joel Hammer Joel at
Thu Nov 8 15:36:03 GMT 2001

I can't help with passwords but:
I run a small home network. As a new user to linux, you will be surprised at
how much grief security/permissions will cause you. About 1/3 of my troubles
come from permissions.
You can really make things easier if you use SHARE security and make guest
ok on your samba server. No passwords, no problems. Reduced security, but
you don't sound like you need it.
Here is what I have in my smb.conf:

[ global ]
security = SHARE       
guest account = ftp

[  public ]
comment = All Files
        path = /
        read only = No
        guest ok = Yes      
Once this is working, you can worry about passwords later.
There are other ways to make things secure without passwords. You can
restrict access to certain ips, for example (hosts allow). And, there is
plenty of security built into linux. For example user ftp will not have many
privileges on your system. 
Once you can get samba working, you will be able to better explore how it

On Thu, Nov 08, 2001 at 06:13:45PM -0500, Bill Seay wrote:
> To begin with, I am a Linux and Samba neophyte.  I apologize for my
> ignorance in advance.  If I have posted this to the incorrect list, I
> apologize again, but I am going bald with frustration over my issue.
> I am attempting to configure Samba version 2.2.2 on a Red Hat Linux 7.1
> machine.  I have set it it up in USER security mode, as I will be
> running it stand alone.  Currently I am only attempting to connect a
> single Windows 98, second edition PC to it.  I set up a Linux user and
> configured his password, then went into SWAT and configured a Samba user
> in the passwords tab with the same Linux password that I previously set.
> Then I logged into the Windows 98 PC with the same username/password
> combination.  I could browse the network neighborhood and see the
> machine, but as soon as I double clicked on it, it pops up dialog box
> that says the following:
> You must supply a password to make this connection.
> Resource:	\\LINUX\IPC$
> Password:	________________________________
> Unfortunately, I have tried every password that I entered into the
> system, but it just will not play nicely.
> I am sure that I have missed something stupid, but the FAQs and
> documentation that I have searched through do not mention this at all.
> I would appreciate any help you could give me.
> Thanks in advance:

More information about the samba mailing list