Problem with GID being set to UID for Samba 2.2.2

Anthony J. Breeds-Taurima tony at
Wed Nov 7 18:32:02 GMT 2001

On Thu, 8 Nov 2001, Indulis Bernsteins wrote:

> OK the problem was that the smb daemons still had the uid/gid mappings 
> cached away somewhere from the first connection attempt.  I went home and 
> tried it again (machines rebooted in the meantime) and all was OK (yay!).
> I suspect this was due to my using xinetd to start the daemons... I'll 
> probably switch back to starting them as daemons 'cos the Redhat 
> configuration files have about a gadzillion spots (+-10E6) where samba 
> daemons are started this way.  Of course, having compiled the source and 
> got samba running now I need to either manually replace all of the SMB 
> files scattered across the RH directories, or get an RPM (or learn how to 
> put together my own RPM!).

In the source tree there is a Packageing subfolder.

I run this nightly to build RPMS from the current CVS snapshot.

SAMBA_RELEASE=`date +%Y%m%d`

set -e

if [ -n "$1" ] ; then
        set -x

cvs update -d -P
cd ${PREFIX}

[ -d  samba-${SAMBA_VERSION} ] && rm -rf samba-${SAMBA_VERSION}

cp -a samba samba-${SAMBA_VERSION}
cd samba-${SAMBA_VERSION}/packaging/RedHat
patch < ${PREFIX}/samba2.spec.tmpl.patch 
cd ..
bin/update-pkginfo ${SAMBA_VERSION} ${SAMBA_RELEASE}
cd RedHat/

The You'd prolly just need:
cd <sambasource>/packaging
bin/update-pkginfo 2.2.2 0.1
cd RedHat/

Then you should end up with:

laughing :)

Yours Tony.

 * "The significant problems we face cannot be solved at the 
 * same level of thinking we were at when we created them."
 * --Albert Einstein

More information about the samba mailing list