Win2000 sharing violation

Anthony aslan at
Mon Nov 5 22:13:02 GMT 2001

Hi everyone.
	I have a problem which I've spent many hours on and now I must turn to the 
Samba community for help. Here's the setup:

-Samba 2.0.10 on RedHat 7.1 (Pentium III 933, 384Mb RAM, 100Gb HDD [40/60])
-Windows 2000 Professional client, SP2
-Windows 95b client
-Users of both Win2k and Win95 machines are mapped to user "aslan" on Samba 
box, with no forcing enabled.

Here's the problem:
-The Win2k machine can create folders and files, but after getting 
properties of a file that has been created in that folder, the folder 
cannot be deleted. The file is deleted, but not the folder. The error 
message reports there has been a sharing violation. However, the Win95 
machine can do anything within it's access rights. Creating directories, 
files and getting properties of these things all works. Also, if I don't 
bring up the properties of the file on the Win2k machine, the files and 
directories can be deleted.
-If I create a folder from the Win2k machine, then create a file in that 
directory, bring up the properties and close them, then go back and try 
deleting that directory, it fails. But I can then delete that directory 
from the Win95 machine.
-On looking at the log files, it appears that access from the Win2k machine 
is falling back to user "nobody", and I have no idea why.

I also tried the "force directory security mode" option and all the related 
options, with no success. "nt acl support" is on by default, so I tried 
turning that off and it made no difference (besides the fact that the 
"Security" tab didn't show up in Win2k any more). I've tried SP1 and SP2 on 
the Win2k machine, both giving the same results. The last thing I tried was 
to install Samba 2.2.2-20011013, and that didn't even work. Following are 
the relevant lines from smb.conf:

	comment = Testing stuff
	path = /sambatest
	read only = No
	force security mode = 0777
	directory mask = 0771
	force directory mode = 0771
	force directory security mode = 0777
	inherit permissions = Yes
	delete readonly = Yes
	dos filemode = Yes

Am I just doing something really stupid, or is there a known problem with 
this? I've just tried deleting the directories I made in the above share 
last night, and I was able to delete them - but I've re-booted this Win2k 
machine a few times since then. But trying to create new directories and 
files just now is giving the same results as explained above. Any help 
whatsoever on this matter would be highly appreciated!

Anthony (aslan at

More information about the samba mailing list