Can't compile under RH 7.2

Jeremy Allison jra at
Mon Nov 5 07:39:02 GMT 2001

On Mon, Nov 05, 2001 at 10:35:24AM -0500, Gregor N. Purdy wrote:
> All --
> Has anyone gotten samba to compile under RH 7.2? I tried:
>    2.2.2       NOPE
>    2.2.0       NOPE
>    2.0.0       NOPE
>    1.9.00      YES
> In the cases of the 2.* versions (and CVS head) I ran ./configure
> and make. In the case of 1.9.00, I edited the Makefile for a non-
> shadow Linux host (and added -lcrypt).
> I'm attaching a typescript file of my latest attempt at CVS HEAD
> compilation. I haven't messed with samba source before, although
> I've been looking through it for a few things since Friday. I
> figure my problem has to be something simple that someone else
> has run in to. The kernel version is 2.4.9-7smp (Red Hat's stock
> SMP kernel for 7.2 -- the latest from up2date).
> I'm wondering if I've got generally broken includes here since the
> complaint is about redefinition of struct statfs...

Yes. RedHat shipped broken system headers with RH7.2.

I have added a workaround into the CVS HEAD and 2.2 sources but
haven't yet added the autoconf test to activate it.

RedHat "solved" the problem for their Samba compile by hacking
out a #include line in Samba.


More information about the samba mailing list