Can't compile under RH 7.2

Gregor N. Purdy gregor at
Mon Nov 5 07:36:07 GMT 2001

All --

Has anyone gotten samba to compile under RH 7.2? I tried:

   2.2.2       NOPE
   2.2.0       NOPE
   2.0.0       NOPE
   1.9.00      YES

In the cases of the 2.* versions (and CVS head) I ran ./configure
and make. In the case of 1.9.00, I edited the Makefile for a non-
shadow Linux host (and added -lcrypt).

I'm attaching a typescript file of my latest attempt at CVS HEAD
compilation. I haven't messed with samba source before, although
I've been looking through it for a few things since Friday. I
figure my problem has to be something simple that someone else
has run in to. The kernel version is 2.4.9-7smp (Red Hat's stock
SMP kernel for 7.2 -- the latest from up2date).

I'm wondering if I've got generally broken includes here since the
complaint is about redefinition of struct statfs...

Thanks in advance for any pointers.


-- Gregor
/     perl -e 'srand(-2091643526); print chr rand 90 for (0..4)'      \

   Gregor N. Purdy                          gregor at
   Focus Research, Inc.      
   8080 Beckett Center Drive #203                   513-860-3570 vox
   West Chester, OH 45069                           513-860-3579 fax

More information about the samba mailing list