Locking Database Error:

Jim LaSalle jjlasalle at home.com
Sun Nov 4 18:07:03 GMT 2001

This was a PITA to fix. I finally came up with this solution. Don't know 
why it works because none of this is referenced in the Makefile. I'm 
guessing it's screwed up because I used the stock samba RPM on the Red 
Hat 7.1 iso CD.

Put these two symbolic links in your /etc/samba directory.

    codepages -> /usr/local/samba/lib/codepages
    smb.conf -> /usr/local/samba/lib/smb.conf

>On Monday, 30 Apr 2001 at 17:37:17 -0700 Trevor Benson wrote:
>I just built a new Redhat 7.1 server. I installed the RPM package from
>ftp.samba.org <ftp://ftp.samba.org>  and after I run the smbd and nmbd I
>still end up with this error below. I have checked this list, and gone
>through the Project Doc's and the FAQ's, I originally posed on the samba
>group, and had no response there.  I am not part of the technical mailing
>list, so if anyone has a suggestion please make sure to reply.  If you would
>suggest I join this list as well, please mention it, I will do it right
>   Nothing seems to reference the locking database not initializing.  Has
>anyone else had this issue?  On a fresh system with the RPM I wouldn't
>expect to have this much trouble, that's why I left the old 6.x server as is
>and tried to move forward with a test box to see if I couldn't resolve this.
>Any help or idea's would be appreciated. The log.smbd and nmbd have NOTHING
>in them at this point. Im not really sure what to do.
>Samba version 2.2.0
>Service      uid      gid      pid     machine
>Failed to open byte range locking database
>ERROR: Failed to initialise locking database
>Can't initialise locking module - exiting

More information about the samba mailing list