samba digest, Vol 1 #661 - 38 msgs

Waltner, Steve swaltner at
Fri Nov 2 11:00:03 GMT 2001

> Hi,
> Hope this list is as fast and as helpful as some other lists I use.
> My main problem is this, I have 2 unix boxes on a network along with a
> couple of windows boxes.
> 1 box runs NetBSD 1.5.2 the other Runs Red Hat Linux 7.0
> I built and set up Samba on both boxes.
> The netbsd one runs fine, I have one share which is the whole disk.  I can
> see it just fine, browse and drop files and get files. Perfect.
> The redhat box is misbehaving, I can see the share just fine BUT it asks
> for a password before it will let me get at it!
> I run the smbclient -U% -L local command on both and both are the same
> (apart from the obvious) and when I run swat the configs are the same, the
> smb.conf files are 
> the same.
> So why does it ask me for a password?
> It seems to be looking for the IPC$ resource instead of the share that is
> set up. Why?
> Thanks in advance
It's either something obvious like you are logged into the Windows system
with an account that doesn't exist on both UNIX systems, or the passwords on
the two UNIX systems are set different or a configuration difference between
the two systems. The password prompt is Windows behavior if the password is
going to be sent in the clear over the network. Compare the
$SAMBA_DIR/private/smbpasswd files on the Linux and NetBSD systems to see if
your account exists on the netBSD system, but doesn't exist in the smbpasswd
file on UNIX, which means you would fall back to plain-text passwords.

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list