print job not showing in queue but still sent to printer...

Paul Sanders sanders_p at
Thu Mar 29 13:26:58 GMT 2001

Good Morning to all:

I am running Samba 2.2a3 on RHL 6.2 and have experience a troubling problem:

a user was printing a large job [~2000 duplex pages] from accesson an NT
workstation to an HP 8100 via the aforementioned samba box.  The problem was
that about half way throught he job the printer began leaving toner splooge on
the output so we needed to pause the queue to fix it - the queue showed as empty
when viewed both from NT and on the samba box.  I tried lpq, lpc status, and
webmin - all showed nothing in the queue.

Now, this job is ~ 50 Mb overall and the printer only has 24 Mb RAM. While it
was printing I observed that the incoming data indicator was showing that data
was being sent:  one page would print [it is actually a merge of a page billing
information and a customized letter duplexed to a single page] , there would be
a 5-10 sec pause and the next page would print and the data light would flash.

This tells me that samba was still despooling to the printer as the job
progressed.  if that is the case, then why is there nothing in the queue that I
can pause whilst repairing the tempermental printer?  The entire job left the
client workstation and was sent to the samba queue [else it would not be
printing inthe first place..] and is trickling out to the printer...but from

The job was obviously too large to entirely spool to the printer RAM so where
is the rest of the job coming from?

I greatly appreciate any input on this issue.  I have tried searching archives
but nothing quite matches this situation.

Thanks in advance...

Paul Sanders

=  :^  ) >

More information about the samba mailing list