username doesn't work

brain at brain at
Tue Mar 27 09:48:10 GMT 2001


I've got samba 2.0.6. My smb.conf file contains:

        comment = My Home
        path = /home/myhome
        username = mary, jack
        read only = No

When I run:    smbclient '//mycomputer/myhome'
and type valid password for mary or jack.

The answer is:

session setup failed: ERRSRV - ERRbadpw (Bad password - name/password pair in a Tree
Connect or Session Setup are invalid.)

When I specify user with e.g. "-U mary" everything goes well.

The documentation says:


    5. Step 5: If a "user = " field is given in the smb.conf file for the service and
       the client has supplied a password, and that password matches (according to the
       UNIX system's password checking) with one of the usernames from the user= field
       then the connection is made as the username in the "user=" line. If one of the
       username in the user= list begins with a '@' then that name expands to a list of
       names in the group of the same name.


"guest user" is set to "no" (by default) so step 5 isn't skipped.

"username" is an alias for "user", but I tried "user" too and result is the same.

smbclient '//mycomputer/myhome%jack' doesn't work too

So something's wrong. Please, can you help me?


Petr `Brain' Kulhavy
<brain at>
Faculty of Mathematics and Physics, Charles University Prague, Czech Republic

George Orwell was an optimist.

More information about the samba mailing list