Samba 2.2 alpha3 released

Fouquet, Errol Errol.Fouquet at
Mon Mar 26 15:51:13 GMT 2001

The problem is not related to LPRng.
I agree that the "-U" flag is only available to root. However my lpr binary
is "setuid root". This means that whomever runs the binary, does in fact run
as the root user. It worked before, I would guess, because 2.0.x versions of
Samba allowed the execution of setuid programs. It appears to me that 2.2a2
does not.

-----Original Message-----
From: William R. Knox [mailto:wknox at]
Sent: Monday, March 26, 2001 9:08 AM
To: Fouquet, Errol
Cc: samba at
Subject: RE: Samba 2.2 alpha3 released

Pardon the somewhat off-topic reply. LPRng will not allow a non-root user
to use the -U flag by default. I couldn't tell you why it worked before.
However, you can edit your lpd.conf file and add the line
"allow_user_setting=name_of_smb_user" to allow the user as which the samba
processes run (in our case nobody) to use this flag. This works like a
charm for us here. Good luck!

			Bill Knox
			Senior Operating Systems Programmer/Analyst
			The MITRE Corporation

On Mon, 26 Mar 2001, Fouquet, Errol wrote:

> Date: Mon, 26 Mar 2001 07:16:40 -0700
> From: "Fouquet, Errol" <Errol.Fouquet at>
> To: 'Jeremy Allison' <jeremy at>, samba at,
>      samba-ntdom at, Samba technical <samba-technical at>
> Subject: RE: Samba 2.2 alpha3 released
> Jeremy,
> First off, I haven't tested alpha3 yet ... but I am using alpha2.
> It appears that setuid binaries are not honored with 2.2a2. Perhaps this
> intentional.
> What I noticed was all print requests sent to Samba never got spooled up
> with LPRng. I set the debug level to 3 for smbd and the logs reported that
> my "lpr" command "gave a 1".
> In order to catch output from the lpr command itself, I created a wrapper
> script and redirected the output to a file. After attempting another print
> request, the lpr output was complaining that the "-U" option can only be
> by root (my print commands in smb.conf all use the "-U" option). The odd
> thing is that the lpr command is setuid root and the previous version of
> Samba functions fine with this option.
> Errol Fouquet - UNIX SysAdmin
> Minerals Management Service, DOI
> 1201 Elmwood Park Blvd.
> New Orleans,  LA  70123
> Phone: (504) 736-3255
> Fax:   (504) 736-2464
> email: errol.fouquet at
[original message deleted to save electrons, a precious natural resource]

To unsubscribe from this list go to the following URL and read the

More information about the samba mailing list