Login Failure

Grant grant at conprojan.com.au
Mon Mar 26 00:21:31 GMT 2001

It seems a lot of people are having problems with log errors that contain
"util_sock.c". Is there somebody from the Samba team who can possibly give
us an insight into why this is happening and why in some instances,
putting all the ips and arbitrary names in /etc/hosts fixes it? There has
been no conclusive replies from anyone on the list so far :(

On Fri, 23 Mar 2001, Wade Hampton wrote:

> Greetings.  Is there something up with Samba and RedHat,
> or with recent kernels, or with some packages that have
> been updated recently?  A lot of us seem to see the 
> same login errors with samba and I have yet to get my
> windows clients to login to my new samba server.  The 
> log messages really don't help.
> I had an old server running Samba 2.0.7 (RedHat 5.0 upgraded
> to nearly 5.2 with 2.0.33).  This server had an uptime of 498 days
> but seemed to crash a few days after upgrading to samba 2.0.7.
> However, since the crash, it has had an uptime of 203 days, but
> really needs to be replaced (slow, on a 10-T lan, old SW, 
> out of disk space, etc.).  I NEVER had any login problems 
> with this server (5-10 clients, infrequent use).
> I replaced this server with a RedHat 6.2 box with updates as of
> a week or so ago.  My other services seem to work fine, but
> I cannot access the samba server.  Server is a Dual PII 300,
> 128M RAM, multiple SCSI disks, NFS exported, light load,
> X is not running (but it is running xmms remotely).  Kernels
> tried were 2.4.0 and 2.2.18 with the same results.
> Clients:  Windows 95 OEM2 in vmware, Win2K SP1 on 
> real hardware.
> Initially, I copied the setup from the older box (which had
> 2.0.7 on it), to the new server, added a few new shares, then
> restarted samba.  I can access using smbclient -L <server name>
> and all seems OK.  My vmware Win95 box (which could connect
> to the old server) can't connect and the samba logs show
> messages identical to those in mail:
> 	"Transport endpoint is not connected"
> 	from "Romanenko M.A." <mikhail at angg.ru>:
> [excerpt from referenced mail:]
> [2001/02/12 17:32:21, 1] smbd/files.c:file_init(216)
>   file_init: Information only: requested 10000 open files, 1014 are =
> available.
> [2001/02/12 17:32:21, 0] lib/util_sock.c:client_addr(1045)
>   getpeername failed. Error was Transport endpoint is not connected
> [2001/02/12 17:32:21, 0] lib/util_sock.c:write_socket_data(540)
>   write_socket_data: write failure. Error =3D Connection reset by peer
> [2001/02/12 17:32:21, 0] lib/util_sock.c:write_socket(566)
>   write_socket: Error writing 4 bytes to socket 4: ERRNO =3D Connection
> =
> reset by peer
> [2001/02/12 17:32:21, 0] lib/util_sock.c:send_smb(754)
>   Error writing 4 bytes to client. -1. Exiting
> [...]
> Per another mail, I tried changing socket options to:
> 	socket options = TCP_NODELAY SO_RECVUF=8192
> Per another mail, I made sure my wins was off and made sure
> that my SMB name, hostname, DNS and /etc/hosts all had
> the same name:  vmwin95 and address in it.  dnslookup 
> vmwin95 <server> works fine.  The samba logs are created
> for vmwin95.  I can ping vmwin95.
> My host lookup options are the defaults.
> All my hosts are static IP addressed.
> I have the same problem with two Win2K SP1 boxes (not VM's,
> but actual computers).  I have not yet tried my Win2K VM.
> This is a private intranet test network and I do not have 
> a hosts allow line in my smb.conf file.  I did verify 
> both forward and reverse DNS mappings on both my
> main and backup DNS server:
> 	nslookup vmwin95
> 	nslookup
> My hosts are on a lightly loaded network through a
> 3COM 10/100 switch.  I am having NO problems pinging,
> nor delays with networking.  Pings are 2-4 ms from
> the virtual 95 -> server, and .6 ms from the server
> to the virtual 95 client.
> My samba server is the primary login controller
> for my windows boxes.  Right now, it is the 
> only box in the workgroup.
> Any help would be most appreciated.
> Cheers,

More information about the samba mailing list