smbclient/mount question

Kelly Martin kelm at
Sat Mar 17 07:56:42 GMT 2001

This is driving me up the wall. I've had a basic samba server up for a
couple of years and it was easy to do. Now with a second server I try to
mount the same shares from the new linux box but I can get nothing to
work. I would use NFS between the linux boxes but the support isn't
compiled into my kernel, and I don't want to tackle that beast tonight...

To test I tried the smbclient first:

   smbclient //myhost/myshare /mnt/mymount username=myname/MYHOUSE

It prompts me for a password but I get an ERRbadpw (Bad password -
name/password pair is in a Tree Connection or Session Setup are invalid.)

Is it a problem with password encryption or something? When I do a
'smbclient -L myhost' I can see the shares. I think my lmhosts is correct
and I have 'name resolve order = lmhosts bcast' in my smb.conf. All the
addresses are internal 192.x with names given to them via the /etc/hosts
file (I'm not running DNS). Using Samba 2.0.7.

So, for another test I decided to create a share on my NT desktop and
tried to attach using my admin username/password... on that one I get an
Access Denied, so I checked the permissions on the NT box and everyone
gets access. What gives? I don't care about access to this one but I am
feeling lost tonight -- I'd really like to get the two linux machines
talking over samba.


kelly's red beet factory
A boy, not a girl in Calgary Canada.

More information about the samba mailing list