smbmount - file permissions on RH7

Dormition Skete dormitionskete at
Thu Mar 8 03:59:10 GMT 2001

Greetings in Christ.

If I change it to uid=nmetsovo the error message does not occur.  However, I 
want the drives to be mounted at boot time, and I don't want others to mess 
with them... or to have to mess with them.  I also don't want our users to 
have to go through a login screen to access a share on another computer.

Redhat has this "User Private Group" (UPG) scheme where each user has their 
own private, primary group.

According to their documentation, if I understand it correctly, one should 
be able to:

mkdir /mnt/MtAthos-c
chown -R root.smbusers /mnt/MtAthos-c

Page 30 RH7 Reference Guide:  (with the names changed)

To allow the users to actually create files in the directory you enter:

chmod 775 /mnt/MtAthos-c

But when a user creates a new file it is assigned the group of the user's 
defualt group (usually "users").  To prevent this you enter:

chmod 2775 /mnt/MtAthos-c

which causes everything in the directory to be created with the "smb" group.

It doesn't seem to be working this way, though.  When RH7 goes to set the 
uid and gid for the created file, I get:

cd /home/nmetsovo
cp .Xclients-default /mnt/MtAthos-c/temp/
cp: preserving permissions for 
'/mnt/MtAthos-c/temp/.Xclients-default':Operation not permitted

It goes ahead and changes the uid and gid to however it is set when I mount 
it, but it gives me this pesky error message, which is killing me...

No matter how I mount this drive, I get this message -- whether I try to 
copy a file through a terminal window, KDE 2.1, or Gnome.  Gnome says: 
"Cannot chmod target file <filename>.  Operation not permitted (1)"

dmesg didn't show anything worth noting.

I don't know what "o" is for, but it is in a couple of examples in the 
documentation.  If you don't start with it, though, it will prompt you for a 
password even if you try to mount the drive as "guest".

I've been struggling with this problem for months -- and putting up with it 
in the meantime -- but I have to get this resolved.  If anyone could please 
shed some light on this I would greatly, greatly appreciate it.

In Christ,

Br. Nicholas

>From: Urban Widmark <urban at>
>To: Dormition Skete <dormitionskete at>
>CC: <samba at>
>Subject: Re: smbmount - file permissions on RH7
>Date: Thu, 8 Mar 2001 00:18:09 +0100 (CET)
>On Wed, 7 Mar 2001, Dormition Skete wrote:
> > I have a group called "smb".
> > I have a user called "smbuser".
> > My user account is a member of the smb group.
> > I have tried chmod 2777 /mnt/MtAthos-c and just plain 777.  Neither 
> > any difference.
> > The directory is set uid=1001, gid=1001  (smbuser and smb)
>For testing purposes, does anything change if you mount it with
>uid=nmetsovo? Does it help if you give a username/password and not just
>login as guest?
>What is the exact error message and the command you are trying?
>Do you get any messages about smb from the kernel? (try dmesg)
> > I have tried mounting the drive every way imaginable.  Here are just a
> > couple of the lines I've tried in my fstab:
> >
> > \\MtAthos\MtAthos-MDoc  /mnt/MtAthos-MDoc smbfs
> > o,guest,exec,rw,uid=1001,gid=1001,fmask=2777,dev,suid 0 0
> > \\MtAthos\MtAthos-c   /mnt/MtAthos-c  smbfs o,guest,dmask=777,fmask=777 
>0 0
> > \\sinai\Sinai-MDoc  /mnt/Sinai-MDoc   smbfs o,guest      0 0
>What is o ?
>To unsubscribe from this list go to the following URL and read the
Get your FREE download of MSN Explorer at

More information about the samba mailing list