smbmount - file permissions on RH7

Urban Widmark urban at
Wed Mar 7 23:18:09 GMT 2001

On Wed, 7 Mar 2001, Dormition Skete wrote:

> I have a group called "smb".
> I have a user called "smbuser".
> My user account is a member of the smb group.
> I have tried chmod 2777 /mnt/MtAthos-c and just plain 777.  Neither makes
> any difference.
> The directory is set uid=1001, gid=1001  (smbuser and smb)

For testing purposes, does anything change if you mount it with
uid=nmetsovo? Does it help if you give a username/password and not just 
login as guest?

What is the exact error message and the command you are trying?
Do you get any messages about smb from the kernel? (try dmesg)

> I have tried mounting the drive every way imaginable.  Here are just a
> couple of the lines I've tried in my fstab:
> \\MtAthos\MtAthos-MDoc  /mnt/MtAthos-MDoc smbfs
> o,guest,exec,rw,uid=1001,gid=1001,fmask=2777,dev,suid 0 0
> \\MtAthos\MtAthos-c   /mnt/MtAthos-c  smbfs o,guest,dmask=777,fmask=777 0 0
> \\sinai\Sinai-MDoc  /mnt/Sinai-MDoc   smbfs o,guest      0 0

What is o ?


More information about the samba mailing list