smbmount - file permissions on RH7

Dormition Skete dormitionskete at
Wed Mar 7 20:04:38 GMT 2001

Greetings in Christ our Saviour.

I am having an enormous amount of difficulties trying to do something that
should be quite easy.  Obviously, I am missing something.  I have read
everything I can find on this, and have tried everything I can think of and

I am trying to mount a Win98 drive on my Redhat 7.0 box.  The mounting is no
problem.  However, when I log into my user account and try to copy a file to
the win98 machine, I always get an error saying I don't have permission to
do this.  The file gets copied, though.

Here's what I have done:

I have a group called "smb".
I have a user called "smbuser".
My user account is a member of the smb group.
I have tried chmod 2777 /mnt/MtAthos-c and just plain 777.  Neither makes
any difference.
The directory is set uid=1001, gid=1001  (smbuser and smb)

I have tried mounting the drive every way imaginable.  Here are just a
couple of the lines I've tried in my fstab:

\\MtAthos\MtAthos-MDoc  /mnt/MtAthos-MDoc smbfs
o,guest,exec,rw,uid=1001,gid=1001,fmask=2777,dev,suid 0 0
\\MtAthos\MtAthos-c   /mnt/MtAthos-c  smbfs o,guest,dmask=777,fmask=777 0 0
\\sinai\Sinai-MDoc  /mnt/Sinai-MDoc   smbfs o,guest      0 0

It appears to be having problems changing from my uid (nmetsovo) to the
smbuser uid.

Somehow I have to get rid of that error message.  It is interferring with
another program I am trying to use.  I realize that this is not a *Samba*
error, but would somebody please help me figure out how to mount this drive
so it doesn't give me this error message every time I try to copy a file to
a windows machine?

I would GREATLY appreciate any help you could give me.

In Christ,

Br. Nicholas

Dormition Skete
A Monastery of the Genuine Orthodox Christians of Greece and the Diaspora.
Synod of Metropolitan Kallinikos of Lamia.

More information about the samba mailing list