Mapping SMB usernames to SCO users

MCCALL,DON (HP-USA,ex1) don_mccall at
Wed Mar 7 15:29:19 GMT 2001

Hi Brian,
It looks like in order to browse, your pc is comming in with a null session
request to 
IPC$, and that is being mapped to the guest account; The message you are
getting generally
indicates that there is no valid user named "nouser" in your /etc/passwd
file.  Is this the case?

-----Original Message-----
From: samba at [mailto:samba at]
Sent: Tuesday, March 06, 2001 6:24 PM
To: samba at
Subject: Mapping SMB usernames to SCO users

I have about 40 SCO  5.0.5 servers on which I am installing samba (I've
tried 2.0.3 and 2.0.7, I'm having the same trouble with both).

For my example, assume the following:

NT user: Administrator  (I have tried other users as well)
samba server: CLASS
guest account (on UNIX server): nouser

A generic Unix account exists called samba.

My goal is to map all Windows users to the Unix user samba.

my username map file looks like:
samba = *

According to the documentation this should map any windows users to the Unix
user samba.  

My problem is, after successfully joining the NT domain, I can see the
computer "CLASS" in network neighborhood, but if I try to browse to it, I am
asked for a username and password.  I'm logged into NT as administrator and
administrator is in the global valid users.

If I look in the smb log, I see "normal" looking things. (I'll be happy to
forward someone a copy if they'd like).  If I look at the log file for the
NT machine, I get very interesting data:

sesssetupX: name=[administrator]
Mapped user administrator to samba
.. name resolution stuff omitted...
Connecting to at port 139
samba is in 1 groups: 50
uid 213 is registered to name samba
Clearing default real name
Chained message
switch message SMBtconX (pid 9520)
ACCEPTED: guest account and guest ok
rejected invalid user nouser
Invalid username/password for ipc$
error packet at line 164 cmd=117 (SMBtconX) eclass=2 ecode=2
Transaction 3 of length 43

Now I could be wrong, but it looks to me like the mapping is working, then
gets broken somehow.  Any pointers here would be greatly appreciated.
Please feel free to email me directly for more details.

here is my smb.conf:

	workgroup = ORLANDO_ADMIN
	netbios name = CLASS
	server string = Class Server
	security = DOMAIN
	encrypt passwords = Yes
	password server = orlando_pdc
	username map = /usr/local/samba/private/
	username level = 3
	log level = 3
	log file = /usr/local/samba/logs/%m.log
	max log size = 50
	load printers = No
	printcap name = /etc/printcap
	local master = No
	dns proxy = No
	wins server =
	guest account = nouser
	valid users = administrator
	admin users = bryan
	create mask = 0774
	directory mask = 0775
	mangle case = Yes

	path = /data/class

	path = /data/fadata/data
	read only = No

	path = /data/class/export
	read only = No



To unsubscribe from this list go to the following URL and read the

More information about the samba mailing list