smb client problem

Svensson, Martin Martin.Svensson at
Fri Mar 2 14:57:40 GMT 2001


We're experiencing a really weird problem with our linux smb client. We map
four directories to a NT4-share from our linux-box (2.2.12).
The problem is that the mount goes through just fine with no complaints and
I can see the files on that share, but,  I can't see new files created with
ls on the nt4-server on the linuxbox but if I run more <filename> I can see
the contents of the file. 

If I edit the files contents from the linuxbox I can see it with ls (and can
copy it to other directories). Then if I change the filename of that same
file on the nt4-server my linuxbox still sees the old filename.. and cp/more
etc just writes "file not found" when I try to do anything with it.

The TCP-connections are up and running (one for each mount) and I don't see
any strange things on the NT4-server. If I run smbclient I see all new files
created on the server and it looks normal.

Dmesg writes these messages:
smb_retry: new pid=25233, generation=6 (which is normal .. right? )
smb_trans2_request: result=-32, setting invalid
smb_retry: new pid=10801, generation=6
smb_retry: signal failed, error=-3
smb_retry: signal failed, error=-3

Does anyone have a clue of what this could be ?

Thanks alot for your help!

Martin Svensson
Server Operations Centre
PHONE: +46 709-540 02 00  FAX: +46 46-540 02 50
DIRECT: +46 709-95 46 86
martin.svensson at

More information about the samba mailing list