UNIX Group Problem

Wolf Paul wolf.paul at alcatel.at
Wed Jan 31 23:55:34 GMT 2001


I am running Samba 2.0.7 on a Compaq Alpha Server under Tru64 5.1.
Previously I ran 2.0.3 under Tru65 4.0F.

Since switching to 2.0.7 and/or Tru65 5.1 I have observerd a number of
strange problems related to UNIX groups.

Previously, everything worked as expected:

A user connected to a share where he had UNIX write permissions; if he
created files and dirs, they were owned by him and his primary group.

If the directory had a different group, of which the user was a member,
he could read/write in this dir depending on the group permissions.

Now things are strange:

A user connects to a share where he has UNIX write permissions; when he
creates files and dirs, they are owned by him but have the group of the
parent dir (which does NOT have the group sticky bit set!).

If the directory does not belong to him, but has a group which is not
his primary group but of which he is a member, he cannot write to that
directory  even though the directory is group writeable.

smbd loglevel 10 output shows that Samba does indeed read the group file
and does indeed know which groups this user is a member of; so why is he
not allowed to write according to the group membership, and why is his
primary group ignored when creating new files and dirs?

Can anyone explain this?


W. N. Paul/KSS(sun) * Alcatel Austria * Scheydgasse 41 * A-1210 Vienna, Austria 
wnp at aut.alcatel.at * +43-1-277-22 x5523 (voice)/x1118 (fax) * +43-1-774-1947 (h)

More information about the samba mailing list