Mounting Windows Shares with Blanks in the Share Name

Steve McClary scm at
Fri Jan 26 18:51:43 GMT 2001

I am trying to mount shares provided by Windows machines on my Linux 
machine (RedHat 7.0) so I can do backups to a tape drive on the Linux 
machine. I can successfully mount several of the shares by including them 
in fstab, like so:

//windowsserver/sharename 	/mnt/sharename 	smbfs 	guest	 0 0

But if I try to do this with a windows share that has a blank space in the name

//windowsserver/share name 	/mnt/sharewithblank 	smbfs 	guest	 0 0

it fails, telling me there's no mount point called "name".

I tried putting quotes around "share name" and putting a "\" before the 
space - still no success.

I can do this

mount -t smbfs //windowsserver/"share name" /mnt/sharewithblank -o guest

and it mounts fine.

Any way to cleanly automate this, or do I need to put the mount command in 
a startup file? If so, where?

Thanks for your help.

Steve McClary

More information about the samba mailing list