problem with write_socket_data and write_socket

Chris Herrmann chris at
Tue Jan 23 21:05:58 GMT 2001

Apparently it is with dns - we've seen the problem on a couple of sites, and
**think** (don't know for sure yet!) that we fixed it by:

- Installing dnscache - if you're running named bind it to the external
interface, and dnscache to the internal
- Make sure samba is using the default lookup list (host wins something from
- Make sure dhcpd.conf has node type 2 , and netbios-name-server =

Hopefully by the end of today I should know whether this has actually worked
for us; email me if you want more information.



-----Original Message-----
From: samba-admin at [mailto:samba-admin at]On
Behalf Of Andreas Marienborg
Sent: Tuesday, 23 January 2001 23:51
To: samba mailinglist
Subject: problem with write_socket_data and write_socket

I got the following problem with samba 2.0.6 running on OpenBSD 2.7

[2001/01/23 12:46:50, 0]
  write_socket_data: write failure. Error = Broken pipe
[2001/01/23 12:46:50, 0]
  write_socket: Error writing 4 bytes to socket 6: ERRNO = Broken pipe
[2001/01/23 12:46:50, 0]
  Error writing 4 bytes to client. -1. Exiting

As far as I have been able to gather from the archives, this is a problem
with revers DNS?

Is there no other way to fix this than by setting up reverse dns?

On our local network we havn't even got forward DNS set up. We use WINS,
but I'm not sure if the ones that set up the NT servers and the domain
have done it correctly.

Anyone got any tips?

Andreas Marienborg			+47 92 28 63 82
omega at

More information about the samba mailing list