Samba installs, runs, but doesn't respond

MCCALL,DON (HP-USA,ex1) don_mccall at
Fri Jan 19 15:55:24 GMT 2001

The smbclient -L command is saying that it can't find a netbios name
"bigserver" on the network.  There could be any number of reasons for this:
is your system's hostname "bigserver"? if not do you have a "netbios name"
parameter in your smb.conf specifying "bigserver"?  
Do you have multiple lan cards and ip addresses in your system?
If you post the results of the following, it might help get a handle on
1. your 'trivial' smb.conf file
2. results of "nslookup bigserver"
3. results of "hostname"
4. results of "uname -a"
5. might also try smbclient -L bigserver -I<ipaddress of bigserver>
   to make sure you are really connecting to who you think you are with
   the name 'bigserver'.

Hope this helps,

-----Original Message-----
From: jpn at [mailto:jpn at]
Sent: Thursday, January 18, 2001 9:23 PM
To: samba at
Subject: Samba installs, runs, but doesn't respond

I'm stumped on this one, and I'm hoping someone can help me.

I've set up Samba systems before, so I think I've avoided most novice
mistakes.  Samba installs fine, seems to run fine, but nothing works.

I'm using the precompiled binaries for Solaris 2.7 - I install the
packages, I disabled the inetd startup (in favor of /etc/init.d
startup), I edited smb.conf, and successfully ran testparm.  I then
start smbd and nmbd using "/etc/init.d/samba start", which appears
to work fine.  I can see the smbd and nmbd programs running, and the
log.smb and log.nmb logfiles appear normal (I've set debug to 1,
so that I get log files as soon as samba starts).

When I run TEST 3 of DIAGNOSIS.txt (smbclient -L sambaserver), I get

# ./smbclient -L bigserver
added interface ip=XXX.XXX.XXX.XXX bcast=XXX.XXX.XXX.XXX
session request to BIGSERVER failed (Called name not present)
session request to *SMBSERVER failed (Called name not present)

running "smbstatus" results in the message:

Couldn't open status file /var/opt/samba/locks/STATUS..LCK

(although /var/opt/samba/locks contains "browse.dat", "", and
"" files).

I've got a TRIVIAL smb.conf file (no hosts allow/deny etc.)

WHAT AM I DOING WRONG?!?!?  I feel like I must be missing SOMETHING, but
for the life of me, I can't figure what it is.  Please, any help would
be appreciated.

I'm told that someone else tried to install Samba on this machine before
using the source code and latest gcc, and THAT didn't work either.  As
far as I can tell, there are no remnants left of that attempt - I
cleaned things up before using the binary packaged version.

Thanks in advance for any help you can give me...

  - john nelson (jpn at

More information about the samba mailing list