Session Request Failed

Urban Widmark urban at
Thu Jan 11 23:13:43 GMT 2001

On Thu, 11 Jan 2001, Gill Potter wrote:

> I have a Unix server that has been connected to an NT box using smbmount for
> quite some time.  All of a sudden I am now getting:
> session request to [ip address]  failed
> I have rebooted the NT machine assuming that it was at fault, but I still
> get the error.  We have not made any changes to this system.  Does anyone
> have any suggestions?  I had upgraded the smb clients to 2.0.7 about a month
> or so ago, but it worked fine then.

You mean that it still worked after upgrading?

You write ip address and not a machine name, what does the command you use
to mount look like?

I am not sure what the purpose of session requests are, but they are done
right after connecting before any authentication (login) or even protocol
negotiation is done. It involves exchanging NetBios name information.

More info can be found in "rfc1002.txt 4.3 and 4.3.2", maybe reading that
will tell you something.

Perhaps someone has renamed something ... ? You could try giving both an
ipnumber and the name of the server in the mount command, like this:
% mount -t smbfs -o username=foo,ip= //netbiosname/share /mnt/smb


More information about the samba mailing list