using smbclient without netbios names

Jason Osborne jason at
Wed Jan 10 06:58:26 GMT 2001

i am no expert, but could it possibly be because the two systems are on
different subnets. From what I understood about the smb protocol, it has
problems going between subnets without a wins server....which may only
provide names for requests. sorry if i'm wrong.

-----Original Message-----
From: samba-admin at [mailto:samba-admin at]On
Behalf Of Craig
Sent: Wednesday, January 10, 2001 12:20 AM
To: samba at
Subject: using smbclient without netbios names

I am trying to connect to computers running windows9x knowing only the IP
address using smbclient.

on windows computers i can type \\ in the address bar and
browse the shares of computers that don't show up in my network
neighbourhood (computers on other subnets don't seem to show up, but i can
still use them by typing the IP in)

I am using smbclient like so:
/usr/bin/smbclient "//" -U "craig" -L ""
session request to failed (Called name not present)
session request to 130 failed (Called name not present)
session request to *SMBSERVER failed (Called name not present)

now the interesting thing is that that command works fine connecting to a
different computer, which is running windows 2000 instead of windows 9x:
/usr/bin/smbclient "//" -U "craig" -L ""
session request to failed (Called name not present)
session request to 130 failed (Called name not present)
Password: .... (it works)

so it works instead of saying *SMBSERVER failed.

this message
explains that i think:

"When you try to connect via NetBIOS, you present a calling NetBIOS name and
a  called NetBIOS name. Usually the called NetBIOS name is the name of the
server in things like \\server\share.
W2K probably only supports two things in the called name field: The NetBIOS
name of the server or *SMBSERVER."

this thread
gets the same error message, but apparently for a different reason (he was
running a solaris nbdaemon)

so my question is, how is that i can use windows9x shares from windows by
typing the IP in (but they don't show up in network nieghbourhood, (although
some close by computers do)) but not with smbclient when all I supply is the
ip address (same as with windows...)?

does windows somehow look up the netbios name and supply it? win9x shares
dont seem to like being accessed by jsut their IP and not their netbios

I tried to make this as clear as possible and let you know what I have
learned so far, i hope it's not too long

thanks in advance,

More information about the samba mailing list