using smbclient without netbios names

Jeff jeffhall at
Wed Jan 10 06:33:49 GMT 2001

Hello Craig,
    Just Quickly I didnt read all of your email but here is what I think....
    Computers not showing across subnets is becuase you probably havent set
branshing across different subnets up in your smb.conf file to display
computers on         different subnet class's or all together different

    And Windows9x and NT perform much better with IP lookups rather then
NetBEUI the only time netbios can be compared to IP lookups is when you have
a     WINS Server usually running on your Domain Controller or when NetBEUI
names are performed with DNS lookups......

    Also using NetBEUI with out a Domain Controller is very iffy it sort of
decides when it wants to display the other computers on your LAN
    Also it takes its time to resolve NetBEUI Names into IP's when your not
using a WINS... or Caching them

Thanks Jeff Hall
NetworkEclipse (02)65844664
Network Admin/Application Programmer

----- Original Message -----
From: "Craig" <9jcm3 at>
To: <samba at>
Sent: Wednesday, January 10, 2001 5:19 PM
Subject: using smbclient without netbios names

> I am trying to connect to computers running windows9x knowing only the IP
> address using smbclient.
> on windows computers i can type \\ in the address bar and
> browse the shares of computers that don't show up in my network
> neighbourhood (computers on other subnets don't seem to show up, but i can
> still use them by typing the IP in)
> I am using smbclient like so:
> /usr/bin/smbclient "//" -U "craig" -L ""
> session request to failed (Called name not present)
> session request to 130 failed (Called name not present)
> session request to *SMBSERVER failed (Called name not present)
> now the interesting thing is that that command works fine connecting to a
> different computer, which is running windows 2000 instead of windows 9x:
> /usr/bin/smbclient "//" -U "craig" -L ""
> session request to failed (Called name not present)
> session request to 130 failed (Called name not present)
> Password: .... (it works)
> so it works instead of saying *SMBSERVER failed.
> this message
> explains that i think:
> "When you try to connect via NetBIOS, you present a calling NetBIOS name
> a  called NetBIOS name. Usually the called NetBIOS name is the name of the
> server in things like \\server\share.
> W2K probably only supports two things in the called name field: The
> name of the server or *SMBSERVER."
> this thread
> gets the same error message, but apparently for a different reason (he was
> running a solaris nbdaemon)
> so my question is, how is that i can use windows9x shares from windows by
> typing the IP in (but they don't show up in network nieghbourhood,
> some close by computers do)) but not with smbclient when all I supply is
> ip address (same as with windows...)?
> does windows somehow look up the netbios name and supply it? win9x shares
> dont seem to like being accessed by jsut their IP and not their netbios
> name.
> I tried to make this as clear as possible and let you know what I have
> learned so far, i hope it's not too long
> thanks in advance,
> craig

More information about the samba mailing list