Upgrade Problems rh6.2 -> rh7.0

Chip Killian chkill at netscape.net
Fri Jan 5 05:30:50 GMT 2001

Hello -

I have recently upgraded my rh linux system from rh 6.2 to rh 7.0.  Prior to 
the upgrade, I had samba correctly configured and working to allow password 
protected shares from the linux box to a win2k box that I also have on a 
private network.  Since the upgrade it has not worked again.  I have tried 
running the following versions of samba:


I copied the smb.conf from the old configuration to the new smb.conf 
location, and I started it up - and not it won't work.  Also, note that the 
win2k box has already had the registry hack to make it send plain text 

In all cases, the win2k box shows the 'server' (that's the netbios name as 
well as the computer name) in the network neighborhood, but will not allow it 
to be expanded.  I have gotten various errors from "semaphore timeout" to 
"network path not found" or "network path not accessible."  I get a constant 
error message in the log that says - 

[2001/01/05 00:15:25, 0] lib/util_sock.c:write_socket_data(540)
  write_socket_data: write failure. Error = Broken pipe
[2001/01/05 00:15:25, 0] lib/util_sock.c:write_socket(566)
  write_socket: Error writing 4 bytes to socket 7: ERRNO = Broken pipe
[2001/01/05 00:15:25, 0] lib/util_sock.c:send_smb(754)
  Error writing 4 bytes to client. -1. Exiting                                

The smb.conf file I've been using is:
# Samba config file created using SWAT
# from home.ritz.2y.net (
# Date: 2000/10/27 00:13:13

# Global parameters
        workgroup = BRAGAW
        netbios name = SERVER
        server string = Samba Main Server
        interfaces =
        security = SHARE
        debug level = 0
        log file = /var/log/samba/log.%m
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        os level = 0
        domain master = Yes
        dns proxy = No
        comment = server linux box
        hosts allow = 192.168.0. 127.

        comment = Home Directories
        path = /home/%u
        writeable = Yes
        browseable = No
        available = No

        comment = All Printers
        path = /var/spool/samba
        printable = Yes
        browseable = No

        comment = Temporary file space
        path = /tmp
        writeable = Yes
        guest ok = Yes

        comment = Chip's Home Directory
        path = /home/cekillia
        valid users = cekillia
        writeable = Yes
        browseable = No
        comment = Mike's Home Directory
        path = /home/mtcrotty
        valid users = mtcrotty
        writeable = Yes
        browseable = No
        comment = Pepper's Home Directory
        path = /home/eljobe
        valid users = eljobe
        writeable = Yes
        browseable = No
        comment = Catholic-ncsu's Home Directory
        path = /home/catholic-ncsu
        valid users = cekillia eljobe mtcrotty 
        writeable = Yes
        browseable = No     

Like I say - it worked before, and now I can't get it to work, and I'm quite 
baffled.  Please help -

Get your own FREE, personal Netscape Webmail account today at 

More information about the samba mailing list