Samba Password Problems

MCCALL,DON (HP-USA,ex1) don_mccall at
Wed Feb 21 14:00:55 GMT 2001

Hello Mark,
It sounds like you did all the right stuff;
A couple of things to check; do you have an entry for 
the NT user in your /etc/passwd file on the samba server?
Even though the user is being authenticated against the NT 
PDC, you have to have the user in your /etc/passwd file so that 
samba knows what uid/gid to use when accessing/creating unix files.
The other issue, about network name not found sounds like the 'Public'
share may be pointing to an invalid or inaccessible unix directory path.
Check to make sure that the 'path = ' parameter under public is pointing
to a valid directory on your linux box, and that you have execute permission
for the appropriate user(s) on each directory in the path.
If none of this makes a difference, you might consider posting your 
smb.conf file with this problem (minus comments).  Also, if you want to 
turn logging on (log level = 10, and log file = /usr/local/samba/log.%m)
and run your test again, and then send me the log.machinename that you get,
I'd be glad to take a quick look at it to see if I can spot anything
Hope this helps,

-----Original Message-----
From: Mark Penkower [mailto:mark at]
Sent: Wednesday, February 21, 2001 8:34 AM
To: samba at
Subject: Samba Password Problems

I just set up a samba Server.

I am trying to access via a Windows NT Workstation on an NT Network.

I added the machine via server manager.  I joined the domain via the
smbpasswd utility.

I modified smb.conf to set security  = domain and
encryped passwords = yes

I told it that the PDC was the password server

The [homes] section says broseable = no
read only = no

testparm says everythiing is correct.

I added the user to samba and put added the password.

The share is not accessable via Network Neighborhood.

I run explorer and manually map to the linux box - it adds username to
the description field and shows 2 folders - one with my user name, and
one named public.

If I click on my username, a box comes up saying incorrect username or
password - When I supply the combination, nothing happens.

If I click on Public, the message is - the network name could not be

I then tried the following at the linux box:

I typed in //smbclient //machinename/public

It showed that it added the correct interface, broadcast and netmask.
It asked for my password - I gave it.  It then specified the domain os
and server.

Then it said" tree connect failed :ERRSRV - ERRinvnetname (invalid
network name in tree connect)."

What do I need to do to see the shares.


Mark Penkower

More information about the samba mailing list