smbclient no connect NetShareEnum failed

Harry Putnam reader at
Wed Feb 14 19:19:57 GMT 2001

Urban Widmark <urban at> writes:

> On 14 Feb 2001, Harry Putnam wrote:
> >  # /usr/local/samba/source/bin/smbclient -d4 -N -L chub
> Does this work better?
> /usr/local/samba/source/bin/smbclient -L chub -U Adminstrator
> All our NT/win2k boxes hate me, unless i give them the a user&password.
> It's always been like that.

OK, that allowed me to see the shares and make sure I had a printer
available.  A little embarrasing too, I had tried that, but misspelled
Administrator like Adminstrator.   Not so easy to spot.

But still the actual printing does not work.

Using  the alpha samba-2.2.0-alpha2 compile, and used the original
RH rpm of rh-print-filters which contains `smbprint'.  Also tried after
copying the `smbprint' from samba-2.2.0 to same directory. I got the
same results either way.

The shows the available share:

smbclient -L chub -U Administrator   -- shows printer EP ready:
Domain=[JINX] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]

        Sharename      Type      Comment
        ---------      ----      -------
        E$             Disk      Default share
        IPC$           IPC       Remote IPC
        D$             Disk      Default share
        print$         Disk      Printer Drivers
        dj-f-cdrom     Disk      
        dj-a-floppy    Disk      
        dj-G           Disk      
        dj-H           Disk      
        G$             Disk      Default share
        EP             Printer   EP
        dj-c           Disk      
        dj-d           Disk      
        ADMIN$         Disk      Remote Admin
        H$             Disk      Default share
        C$             Disk      Default share


And an attempt at printing from my linux box to the w2k machine gives
no usefull debug output:
      # lpr -V file
	LPRng-3.6.24, Kerberos5, Copyright 1988-2000 Patrick Powell,
	<papowell at>
	sending job 'root at reader+501' to lp at localhost
	connecting to 'localhost', attempt 1
	connected to 'localhost'
	requesting printer lp at localhost
	sending control file 'cfA501reader.local.lan' to lp at localhost
	completed sending 'cfA501reader.local.lan' to lp at localhost
	sending data file 'dfA501reader.local.lan' to lp at localhost
	completed sending 'dfA501reader.local.lan' to lp at localhost
	done job 'root at reader+501' transfer to lp at localhost

The job gets spooled but never sent or printed:

	 # lpq
	Printer: lp at reader 
	 Queue: 1 printable job
	 Server: pid 22502 active
	 Unspooler: pid 22503 active

	 Status: processing 'dfA501reader.local.lan', size 15, format 'f',
	 IF filter 'filter' at 10:07:33.010

	 Rank   Owner/ID                  Class Job Files                 Size Time
	active root at reader+501              A   501 file                    15 10:07:32

This is a redhat 7.0 machine.  My printcap looks like:

	# This printcap is being created with printtool v.3.48
	# Any changes made here manually will be lost if printtool
	# is run later on.
	# The presence of this header means that no printcap
	# existed when printtool was run.
	##PRINTTOOL3## SMB uniprint NAxNA letter {} 
    ## U_EpsonStylusColor stcany {}

More information about the samba mailing list