lexmark z52 and samba

Stephen L Arnold sarnold at earthling.net
Mon Feb 12 07:14:56 GMT 2001


I've been trying to setup the Lexmark Z52 as a shared printer (via 
samba) but I'm not getting very far :(

I have the Linux driver from Lexmark installed and working, 
however, the raw print queue I setup for samba isn't working (at 
least not from the client side).  The Lexmark driver reports 
"communication failure..." and if I turn off driver<->printer 
communication, then it just fails silently (but looks like it's 

I also tried a postscript driver on the windoze side, and the test 
page prints color, but not Netscape.  I tried an HP PS driver 
first, but that didn't work (it printed the source code) but I had 
a modicum of success with the Apple PS driver.

Here is my printcap entry:

and this is my printer share:

   comment = Lexmark z52 raw
   path = /var/spool/lpd/lp0 
   print command = lpr -b -P%p %s
   printer name = lxraw
   browseable = no
# Set public = yes to allow user 'guest account' to print
   guest ok = yes
   writable = no
   printable = yes

I changed the permissions on the spool dir above to work with 
samba, but the lp0 share doesn't show up right in NetHood, but I 
can see one for lxraw.  I think I hosed something up...

Anybody got some tips for the raw printer setup and/or a good 
windoze PS driver for decent color, I'd really appreciate it.

Thanks in advance, Steve

More information about the samba mailing list