Mounting samba shares

Christopher Robison eeyore at
Mon Feb 5 23:10:24 GMT 2001

Hi Chris,

I had this exact same problem, and have solved it, sorta -- though not with
mount.  I use smbmount for this.

In the man page for smbmnt (used by smbmount), it suggests that it is meant
to be installed setuid root. It wasn't on my system. I set it (anyone know
of any security problems with this?) and smbmount works.  I use a mount
point under my user directory, and have the command in my Gnome startup so
it only runs when I log in.


> -----Original Message-----
> From: samba-admin at [mailto:samba-admin at]On
> Behalf Of Chris Jensen
> Sent: Monday, February 05, 2001 4:59 PM
> To: samba at
> Subject: Mounting samba shares
> Hi,
> I'm trying to mount samba shares onto the file system, but at the moment
> i only seem to be able to mount them as root. I've tried changing the
> permissions on the mount point and even mounting it on a subdir of my
> home directory but mount just keeps telling me that only root can do
> this. I've put an entry for the mount in /etc/fstab with the user
> option, what have i missed?
> I'm using samba 2.0.7 on RedHat 7, help would be much appreciated.
> --
> ---------------------------------------------------------------------
> Chris Jensen cjensen at
> Educational Experience (Australia)
> Postal Address: PO Box 860, Newcastle NSW 2300
> Freecall:       1-800-025 270      International: +61-2-4923 8222
> Fax:            (02) 4942 1991     International: +61-2-4942 1991
> Visit our online Toy store!
> ---------------------------------------------------------------------

More information about the samba mailing list