SAMBA Really Slow

John Supplee John at
Mon Feb 5 15:44:14 GMT 2001

David Collier-Brown wrote:
> Can you fake up a script that does 60 ftp's of the same-size
> files?  This will tell us if it's a Samba problem (probbaly
> specific to the particular application) or if its something
> like an ethernet card pooping out under load.

> You might also try changing the script to do 60 "gets" with
> smbclient.

>	if ftp is slow too, it's probably the network
>	if ftp is fast, then
>		if smbclient is slow, it's samba
>		if smbclient is slow, it's something else

I'll try to do this sometime.  Seriously doubt it is a problem with the
network card.  Large file transfers work very quickly and it is the samba
process that is chewing up all the CPU time (I didn't think that could be a
symptom of a slow network card).

> Ps: what was the application?

It is a MS Visual FoxPro 6.0 application.

I found a submission to this list with a similar problem that was never
answered (it is included at the bottom of this message).  I think it is a
problem with some setting because I have read of other FoxPro users having
no trouble with accessing files on a Samba server.


P.S. I also tried Samba 2.2.0alpha2 but it gave me the same result.

FoxPro Files in Samba


To: Multiple recipients of list SAMBA <samba at>
Subject: FoxPro Files in Samba
From: "Carlos Alejandro Aguero" <caa at>
Date: Mon, 6 Dec 1999 08:31:30 +1100
Reply-To: caa at
Sender: samba at


I installed RedHat 6.0 as a Server and used Win95 as a WorkStation.-
I also installed Samba 2.0.3 in the Server and moved several FoxPro Files
from a
Win95 WorkStation to Samba shares.-
It all seams to work fine but...
My Application in FoxPro checks for files integrite in the beggining of it,
and opens and closes all neccesary files.-
This also seams to work fine, I can get to use my App. with no error
This checking of 69 files that in my old peer-to-peer Lan in Win95 takes
5 seconds, in the Linux Box takes about 3 minutes!!!
I read and tried all documents in Samba about Diagnosis and Speed, I tried
all the changes suggested (socket option, read size, read raw, share mode,
oplocks, etc...)
None gave a great difference.-
I suposse that there is something with the way Linux/Samba is opening and
closing files, because I cannot find error messages in logs either.-
I use debug level in 3 and no Warning message showed up.-
Finally, I upgraded my Samba to Version 2.0.6, but no difference.-

Can somebody tell me, What am I missing???
Thanks in advance.

Carlos Alejandro Aguero

More information about the samba mailing list