Troubles with permissions & smbmount

Brian Poole rajak at
Fri Sep 22 08:43:48 GMT 2000

Hello all,

Despite numerous efforts to knock over this wall using my head it doesn't
appear to be working. I got the wall a bit bloody and my head to spin a
bit, however it doesn't appear to be yielding. Hopefully someone here can
point me in the proper direction to get _around_ the wall :).

That being said, here is the problem. I am attempting to mount
//SERVER/directory from a Windows 2000 Professional machine onto a Linux
machine running a 2.2.13 kernel. I am using samba 2.0.7 with the
smbmount command of 'smbmount //SERVER/directory /mnt-point/ 
-ofmask=777,dmask=777,rw,guest'. I mount the share as root with no
complaints from smbmount. 

So far so good, I can write to any file that is already there via any
user, ie I can write to /mnt-point/file as long as it existed on the share 
before I tried to write to it. I can also write to subdirectories of
/mnt-point/ as well, thus I can create files named /mnt-point/subdir/file
or delete existing files in the subdirectory, as long as it existed when
I mounted the share. 

The problem is that I can't make new files directly under the root of the
share _unless_ I'm root, eg I can't 'touch /mnt-point/file' as
another user. Looking at the permissions I see that /mnt-point/ is the
only dir/file that does _not_ follow the 777 permissions I specified
during mounting. Instead it offers only 555. I have kicked it around a few
times and I have yet to ever see it offer write permissions at

First I thought that this was simply a share problem, the W2K server just
didn't want me to write there. However using smbclient ( 'smbclient
//SERVER/directory ""), not only does it connect fine but I also have full
write access to directory/. Therefore I would conclude that the W2K server
is indeed sharing it with the necessary permissions.

I have tried all the desperate things people like myself always try, like
chmod'ing the mount point before I mount the share, even though I know it
is not supposed to be related. This of course failed. I wonder if the
kernel might be out-of-date, but ATM I don't have the possibility of
rebooting the machine for a kernel upgrade unless it is absolutely
necessary (and yes, I know < 2.2.16 kernels have a security hole, it just
isn't a big concern in this case). I'll probably end up upgrading the
kernel in the next few days if no other solution pops up, but I thought I
should try here first.

There she is, in one-line, I am unable to mount a share with the root
directory of the share being writable. Suggestions?



More information about the samba mailing list