samba 2.05a on debian

Alex King alex at
Wed Sep 13 21:10:14 GMT 2000

Yes, the potato (latest stable) debian package of samba will not run with
2.0 kernels.  I assume you are running the slink (previous stable)
distribution. There are three options I would consider, all invlolve using
the potato samba package (which handles W2K).

1. Upgrade your entire system to potato, then install a 2.2 kernel.  This
is probably the easiest, because the packaging system will tell you what
configs you need to look at and update.

2. Upgrade only the packages that are affected by the kernel change, then
install a 2.2 kernel.  This is a more conservative option.
You will need to research what packages need to be updated to handle the
2.2 kernel (there used to be a list on the debian web site somewhere)

3. Stay with the 2.0 kernel and all your current packages, but download the
potato samba source package and recompile it for your machine.  (I have the
idea that the package will cleanly compile on a slink system, but I don't
really know - you are on your own with this.)  You will need to work out
the debian compiling and packaging system (quite complex but very nice once
you understand it) and work out what development packages are needed to
compile it.  This option requires the most work, but is the most
conservative option.

I would reccommend the first option though, if you try to maintain an older
system you will run into other compatablity and security problems....

> From: Juha Pesonen <jp at>
> Organization: Grenwill Oy
> To: samba at
> Subject: samba 2.0.5a and win2000
> Hello,
> I have tried to get samba 2.0.5a on Debian Linux (kernel 2.0.36) working
> with window$ 2000 Professional clients, but browsing in win exploder
> doesn't work. win98 works perfectly so the problem must be in some
> security issue that's different in w2k. The win2k client sees the Linux
> box ok in the network nh, but that's it.
> If I give absolute path (net use x: \\linuxbox\sharename) to net use
> command I can mount samba shares. net view \\linuxbox gives 'System
> error 1727' and 'remote procedure call failed and did not execute'.
> First time after reboot w2k client asks for password but after entering
> one the same error message comes up.
> I've also tried the newest samba release, but then nothing works, not
> even with win98 (due to kernel version ??). Putting the registry update
> into win2k (enable plain password)  and changing the encrypt password =
> no in smb.conf doesn't help.
> The linux box running samba is also WINS server for our network, isn't
> nmbd the one who's responsible of browsing functions in samba?
> I think the problem is not with name resolution because wins works fine
> with all our windows machines. Only protocol we use is TCP/IP.
> Thanks, Juha

More information about the samba mailing list