samba 2.0.5a and win2000

Juha Pesonen jp at
Wed Sep 13 14:56:29 GMT 2000


I have tried to get samba 2.0.5a on Debian Linux (kernel 2.0.36) working
with window$ 2000 Professional clients, but browsing in win exploder
doesn't work. win98 works perfectly so the problem must be in some
security issue that's different in w2k. The win2k client sees the Linux
box ok in the network nh, but that's it.

If I give absolute path (net use x: \\linuxbox\sharename) to net use
command I can mount samba shares. net view \\linuxbox gives 'System
error 1727' and 'remote procedure call failed and did not execute'.

First time after reboot w2k client asks for password but after entering
one the same error message comes up.

I've also tried the newest samba release, but then nothing works, not
even with win98 (due to kernel version ??). Putting the registry update
into win2k (enable plain password)  and changing the encrypt password =
no in smb.conf doesn't help.

The linux box running samba is also WINS server for our network, isn't
nmbd the one who's responsible of browsing functions in samba?

I think the problem is not with name resolution because wins works fine
with all our windows machines. Only protocol we use is TCP/IP.

Thanks, Juha

More information about the samba mailing list