printing to nt printer

podda dpathirana at
Mon Sep 11 14:38:55 GMT 2000

Mike Brodbelt wrote:

> > i have samba 2.06 running on a win nt lan. pdc is the nt server. my
> > server is shinning and kicking but the only problem that i have is
> > sharing the nt printer - lexmark optra k 1220 i tried using printtool,
> > created the spooler, edited the print cap, and also edited the smb.conf
> > file.
> > i also tried to print without the samba services, but it didn't work,
> > probably because tcp/ip print services are not enabled in this lan. but
> > in some documents i read that there is a bug in samba printing services
> > in 2.06 is it true?
> > i also read that ms have modified their smb interface making it more
> > difficult to  connect samba servers to win nt. is this true?
> > anyway i can't figure out what's going wrong with the printing. any
> > suggestions and advice is most welcome.
> >
> > here's my printcap
> >
> > lp:\
> >      :sd=/var/spool/lpd/lp:\
> >      :mx#0:\
> >      :sh:\
> >      :af=/var/spool/lpd/lp/acct:\
> >      :lp=/dev/null:\
>                 ^^
> !!! Is your filter doing something smart? If not, this won't get very
> far...
> >      :if=/var/spool/lpd/lp/filter:
> Which filter is this???
> Samba printing is mostly about sharing Unix connected printers to NT/9x
> clients. If you want to print via a Samba share to an NT connected
> printer, then your input filter should probably be calling smbclient to
> transfer the print job. If you're doing this from an NT client  - why
> use Samba to print share at all??? If you're going from a Unix client,
> you'll need a print filter that translates the job into something your
> printer can handle (probably using ghostscript), and then transfers it
> with smbclient.
> Mike.


thanks for helping,

what i want do is to share a printer in a win NT 4 sp 5 lan with my linux
box ( mandrake 7.1 )
i figured out two ways to do that and tried both. But sadly none of them
worked for me.  this is what i tried

1. printing raw postscript directly to the shared printer ignoring
NT spooler. this can be done with TCP/IP print services. but the thing is
that the printer flushes its buffers and ignores the job. But with netstat i

can see my machine connecting with the printer. i couldn't figure out why it

does that.

2. is to setup a samba server ( 2.06 ) and to share the printer with the NT.

i setup the server and modified the smb.conf to include printer details.
here is my smb.conf

   printcap name = /etc/printcap
   load printers = yes
   printing = bsd
   comment = All Printers
   browseable = yes
   public = yes
   guest ok = no
   writable = no
   printable = yes
   path = /var/spool/lpd/lp
   printer = lp

here's my printcap


i don't know much about the filter. but it was setup using the printtool. in

printtool i set the printer as a smb/win NT printer.

i also included server,service and user details in the .config file. when i
send something to printer the document gets spooled locally and my port is
also active. but the printer prints nothing. and the document
doesn't get spooled in the nt spooler.

i'm not sure if it has any thing to do with the spooling system. i'm
using bsd. i don't know much about ppr and lprng.

i don't know what is wrong, i can access any other shares in the NT lan.

any advice is welcome,



More information about the samba mailing list