Red Hat 6.2 Samba 2.0.6 Help...

Tom Corr tomcorr at
Sat Sep 2 22:15:55 GMT 2000

I'm running Red Hat 6.2 with Samba 2.0.6.  I am of course starting to
experience difficulty.  I am running a simple network, consisting of a
single Win98 PC that is connected via a hub to my Linux server.   The
two computers can communicate just fine, ie ping works, telnet, and
Exceeds X-Server work without a problem.  However my Samba does not

Here are the symptoms.   At this point I would like to mention that you
may disregard the Win 98 PC at this point.

On the Linux server I run the following command:

smbclient -L alpha (my server name)

alpha:/home/tcorr$ smbclient -L alpha
added interface ip= bcast=
session setup failed: ERRSRV - ERRbadpw (Bad password - name/password
pair in a Tree Connect or Session Setup are invalid.)

I've read that I can use a -U option, so I've entered:

smbclient -L alpha -U tcorr%password
and I connect just fine, ie my list of shares come up as specified, just
as in the list below...

I can also do the following, where I enter the password at the prompt:
alpha:/home/tcorr$ smbclient -L alpha -U tcorr
added interface ip= bcast=
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 2.0.6]

        Sharename      Type      Comment
        ---------      ----      -------
        oracle         Disk      Oracle Stage Directories
        tmp            Disk      Temporary file space
        apache         Disk      Apache HTTP Directory
        cdrom          Disk      Alpha CDROM Mount
        IPC$           IPC       IPC Service (Alpha's Samba Server)
        tcorr          Disk      Home Directories

        Server               Comment
        ---------            -------
        ALPHA                Alpha's Samba Server

        Workgroup            Master
        ---------            -------
        WORKGROUP            ALPHA

The key appears to be to have the -U option specified.   I think I am
having a password problem, and I think it has something to do with the
way I installed linux.  I used to use Red Hat 6.1 without any problems
(don't ask why I tried to upgrade, stupid, stupid, stupid).  Anyhow,
when I upgraded (by saving my old config files, and then re-installing)
I know I was asked about Password methods.  I think that is what is
getting me now.    I believe I choose standard/pam when I installed
linux, I don't know how to tell???

I have been reading, of course, DIAGNOSIS.txt by Andrew Tridgell, step 3
is where all of this is coming from, step 7, however, smbclient
//alpha/tcorr works just fine when I am prompted for a password.

Any suggestions would be helpful???


More information about the samba mailing list