Samba - problem sharing Unix printers

Mike Box mbox at
Fri Oct 20 20:37:14 GMT 2000

I must have a problem with ownership of the Samba directory that holds the 
spooled file to be printed.  The only way that I can get a file to print on a 
Unix shared printer from a Windows computer is to define the spool area R/W to 
world, which is certainly not acceptable.  I've tried having root, lp, and 
nobody as owners with no luck.  Also, I've tried "guest ok = yes".  What am I 
missing?  Below is the [printers] definition from my smb.conf file on a Solaris 
7 computer.

Thanks, in advance, for your help.

Mike Box                       Phone: (540)231-9506
Systems Administrator            Fax: (540)231-3863
Department of Statistics      E-mail: Mike.Box at
Virginia Tech

guest account = nobody
printing = SYSV
   comment = All Printers
   print command=/usr/bin/dos2unix -ascii %s | /bin/lp -d %p -s | rm %s
   browseable = no
   printable = yes
   public = yes
   writable = no
   create mode = 0700
;  guest ok = yes

More information about the samba mailing list