[SOLVED?] write_socket_data bug

Kerry Koppert k.koppert at taranaki.ac.nz
Wed Nov 29 19:47:08 GMT 2000

The process of setting up reverse DNS depends on
a) What operating system you are using
b) The DNS server you are using.
c) What range of IP addresses you want to do reverse lookups for.

Assuming a unixy type OS, Bind 8 and 192.168.0/24 then you need to edit the
/etc/named.conf file and add something along the lines of
zone "0.168.192.in-addr.arpa"{
        type master;
        file "rev.192.168.0";

The file rev.192.168.0 would then contain

@               IN      SOA     your.name.server.   root.your.name.server. (
                        2000102700 ; serial
                        10800 ; refresh
                        3600 ; retry
                        604800 ; expire
                        86400 ; default_ttl
                                ; default ttl when ttl not specified
@               IN      NS      your.name.server.
@               IN      NS      your.delegating.nameserver.
@               IN      NS      your.secondary.server.
1              IN      PTR     the.machine.
etc, etc....

Under linux, linuxconf simplifies this process.

----- Original Message -----
From: Steve McClary
To: Otto Giesenfeld
Cc: samba at samba.org
Sent: Wednesday, November 29, 2000 7:16 AM
Subject: RE: [SOLVED?] write_socket_data bug

This sounds like exactly the solution to the problems I've been having -
could someone describe the process of adding reverse DNS in simple terms for
novices like me?

Many thanks - the list has been quite helpful and I appreciate the gathered
wisdom of all you subscribers.

Steve McClary

At 04:46 PM 11/28/2000 +0100, Otto Giesenfeld wrote:

I can confirm that adding reverse address lookup seems to solve the problem.
Since we added reverse DNS about a week ago, there has not been a single
write_socket_data error message in the samba logs. Many thanks for this
useful tip.

Otto Giesenfeld

> -----Original Message-----
> From: Lee Howard [mailto:faxguy at deanox.com]
> Sent: Wednesday, November 15, 2000 8:02 PM
> To: samba at us5.samba.org
> Subject: [SOLVED?] write_socket_data bug
> Folks, I think that my write_socket_data problems have been
> solved thanks
> to a good pointer by someone last week on the list.
> The system in question runs named in addition to smb, and I
> did not have a
> reverse-DNS file set up for the local, private-IP
> (192.168.x.x), domain.
> Since I did that on Friday afternoon these are my logs:
> [root at virtue samba]# grep "write_socket_data" * | grep "2000/11/13"
> log.smb:[2000/11/13 16:01:39, 0]
> lib/util_sock.c:write_socket_data(540)
> [root at virtue samba]# grep "write_socket_data" * | grep "2000/11/14"
> [root at virtue samba]# grep "write_socket_data" * | grep "2000/11/15"
> [root at virtue samba]#
> Normally, this system has had about 10 write_socket_data
> errors per day
> since the errors started occuring, so the logs listed above
> show a dramatic
> improvement, and my guess would be that I probably won't see
> any more of it
> in the degree that I have seen it before.
> Thanks all,
> Lee Howard

More information about the samba mailing list